Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#3 allow openssl instead of internal md4-patch

closed-rejected
nobody
None
5
2007-10-25
2004-09-02
Tobias Olsson
No

configure.ac patch to allow --with-ssl
also patches md4.h to #include config.h

This is ripped straight from wget. As I don't understand all of the
autoconf magic, there could be bugs, but "it works for me"(tm).

This patch was necessary to run ed2k_hash under amd64, because the
ed2k_has internal md4-function is broken for that architecture.

Wget is GPLv2.

How to patch and get it compiling:

cd ed2k_hash-0.4.0
patch -p1 <../ed2k-openssl.patch
aclocal
automake
autoconf
./configure --with-ssl
make
make install

Discussion

  • Tobias Olsson
    Tobias Olsson
    2004-09-02

    allow openssl instead of internal md4-patch

     
    Attachments
  • Adam Dunn
    Adam Dunn
    2006-05-19

    Logged In: YES
    user_id=709224

    I wish I'd seen this patch earlier. I think I have the
    internal md4 fixed, I'm just waiting to get some time in a
    32-bit environment to test any 32-bit regressions I may be
    causing. You can track my progress at
    http://sourceforge.net/forum/forum.php?thread_id=1494945&forum_id=199455

     
    • status: open --> closed-rejected
     
  • Logged In: YES
    user_id=583691
    Originator: NO

    Wow, it's been more than 3 years! It seems there still are people using ed2k_hash, so I'm going through the list of patches/bugs.

    I'm not going to apply this openssl patch though, since the OpenSSL license and the GPL are not entirely compatible. Sorry 'bout that, I didn't know myself. I'm not really too keen on other external libs either. The md4 hash routine has been fixed now anyway, so it should hopefully be ok at least until we get 128bit boxes.