#67 connector exception

1.0 M3 RC3
open
Mike Gresens
5
2011-04-01
2011-04-01
No

Hi,
I use ECUT with Momentics, an Eclipse derivate. When I try to assign a connector to a project I get:
!ENTRY org.eclipse.ui 4 0 2011-04-01 15:01:15.064
!MESSAGE Unhandled event loop exception
!STACK 0
java.lang.NullPointerException
at net.sf.ecut.internal.ui.dialogs.ApplyEcutConnectorDialog.getConfigurationNames(ApplyEcutConnectorDialog.java:237)
at net.sf.ecut.internal.ui.dialogs.ApplyEcutConnectorDialog.createBuildConfigurationControls(ApplyEcutConnectorDialog.java:231)
at net.sf.ecut.internal.ui.dialogs.ApplyEcutConnectorDialog.createDialogArea(ApplyEcutConnectorDialog.java:208)
at org.eclipse.jface.dialogs.TitleAreaDialog.createContents(TitleAreaDialog.java:147)
at net.sf.ecut.internal.ui.dialogs.ApplyEcutConnectorDialog.createContents(ApplyEcutConnectorDialog.java:105)
at org.eclipse.jface.window.Window.create(Window.java:431)
at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:1089)
at org.eclipse.jface.window.Window.open(Window.java:790)
at net.sf.ecut.internal.ui.actions.ApplyEcutConnectorAction.run(ApplyEcutConnectorAction.java:73)
at org.eclipse.ui.internal.PluginAction.runWithEvent(PluginAction.java:251)
at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:584)
at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:501)
at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:411)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1003)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3910)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3503)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2405)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2369)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2221)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:500)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:493)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:113)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:194)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
at org.eclipse.equinox.launcher.Main.run(Main.java:1311)

Would be nice if you could fix it, or tell me what could be the matter.

Kind regards
Christian

Discussion