Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#19 configure error on FreeBSD

v1.0_(example)
open
nobody
None
1
2013-01-20
2013-01-19
Anonymous
No

I git clone the newest ECL and do the following:
$./configure --prefix=/home/***/ecl
...
configure: error: Oops, mp_limb_t is 32 bits, but the assembler code
in this configuration expects 64 bits.
You appear to have set $CFLAGS, perhaps you also need to tell GMP the
intended ABI, see "ABI and ISA" in the manual.
configure: error: Failed to configure the GMP library.

1 Attachments

Discussion


  • Anonymous
    2013-01-20

    When building on *BSD systems the libraries are not immediately available to all programs: you have to explicitly tell ECL where to locate them. Can you try configuring with with the following command line?

    ./configure CPPFLAGS=-I/usr/local/include LDFLAGS=-L/usr/local/bin

     


Anonymous


Cancel   Add attachments