No one know what ioctl might be called every time ecl starts? I have tried disabling as many options as I could and I always get this error.

On Sun, Mar 28, 2010 at 3:50 PM, Ryan Hope <rmh3093@gmail.com> wrote:
When I try running ecl on my arm device I get the following error:

Lisp initialization error.
[22: Invalid argument]

...over and over then segfaults.

If I strace ecl I can track the "Invalid argument" down to:

close(4)                                = 0                                                                                                   
munmap(0x35577000, 4096)                = 0                                                                                                   
open("/dev/urandom", O_RDONLY|O_LARGEFILE) = 4                                                                                                
fstat64(4, {st_mode=S_IFCHR|0666, st_rdev=makedev(1, 9), ...}) = 0                                                                            
ioctl(4, SNDCTL_TMR_TIMEBASE or TCGETS, 0x9ed40a44) = -1 EINVAL (Invalid argument)                                                            
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x35577000                                                        
read(4, "Bn2\177\255#\fQ\261\310\232\3304\252d`\"\243\357i\240\235"..., 4096) = 4096                                                          
close(4)                                = 0  


Any help would be appreciated.

-Ryan