Should be fixed now. It is also in CVS by now.

On Sat, Mar 27, 2010 at 3:31 AM, Seth Burleigh <seth@tewebs.com> wrote:
I tried recompiling ecl from git and got this:

Cannot find the external symbol PREBUILT-SYSTEM in #<"ASDF" package>.
Available restarts:

1. (ABORT) ABORT


On Sat, 2010-03-27 at 00:12 +0100, Juan Jose Garcia-Ripoll wrote:
> On Sat, Mar 27, 2010 at 12:11 AM, Juan Jose Garcia-Ripoll
> <juanjose.garciaripoll@googlemail.com> wrote:
>         On Fri, Mar 26, 2010 at 9:35 PM, Seth Burleigh
>         <seth@tewebs.com> wrote:
>                 Im guessing that theres some mechanism in place to
>                 prevent users from
>                 loading those static library.asd files from regular
>                 lisp code, because
>                 directly evaluating (require 'utils) from my c program
>                 works perfectly,
>                 no errors.
>
>
>         You are guessing too much. Sorry for letting you write and
>         write without answer, but your flow of emails just coincided
>         with me travelling a long way, disconnected.
>
>
>         The *.asd file that ASDF was producing was missing a detail,
>         that is :class asdf:prebuilt-system I have uploaded a patch
>         that fixes this, but I could not test it. Hope it solves your
>         problem.
>
>
> BTW, the patch is only in GIT because SF is refusing connections right
> now.
>
>
> Juanjo
>
> --
> Instituto de Física Fundamental, CSIC
> c/ Serrano, 113b, Madrid 28006 (Spain)
> http://tream.dreamhosters.com





--
Instituto de Física Fundamental, CSIC
c/ Serrano, 113b, Madrid 28006 (Spain)
http://tream.dreamhosters.com