$ecl 
ECL (Embeddable Common-Lisp) 12.2.1 (git:446a5ff95d143aa9726326882d7e37b3c0ce9526)
Copyright (C) 1984 Taiichi Yuasa and Masami Hagiya
Copyright (C) 1993 Giuseppe Attardi
Copyright (C) 2000 Juan J. Garcia-Ripoll
ECL is free software, and you are welcome to redistribute it
under certain conditions; see file 'Copyright' for details.
Type :h for Help.  
Top level in: #<process TOP-LEVEL>.
> (defun x ()())

X
> (compile 'x)

;;; Loading #P"/opt/ecl/lib/ecl-12.2.1/cmp.fas"
;;; OPTIMIZE levels: Safety=2, Space=0, Speed=3, Debug=0
;;;
;;; End of Pass 1.In file included from ./ecl/ecl.h:35,
                 from ./ecl/ecl-cmp.h:18,
                 from /private/var/folders/wy/hrmb8g3j37d11721mk55jmx80000gn/T/ecl0012PDlYX.c:5:
./ecl/config.h:485:27: error: arch/fpe_x86.c: No such file or directory

;;; Internal error:
;;;   ** Error code 1 when executing
;;; (RUN-PROGRAM "gcc" ("-I." "-I/opt/ecl/include/" "-g" "-O2" "-fPIC" "-fno-common" "-g" "-O2" "-fPIC" "-fno-common" "-D_THREAD_SAFE" "-Ddarwin" "-O2" "-w" "-c" "/private/var/folders/wy/hrmb8g3j37d11721mk55jmx80000gn/T/ecl0012PDlYX.c" "-o" "/private/var/folders/wy/hrmb8g3j37d11721mk55jmx80000gn/T/ecl0012PDlYX.o"))
X
NIL
NIL
> ^D
 
I configure ecl with the '--with-fpe=NO' option, and this still happens both with ecl v11.1.1 and v12.2.1 on macosx(darwin11 x86_64) and linux-2.6.33(x86_64)

Anyone met this?

--
Best Regards,
            ----  KDr2
/***************************************
 *    site   : http://kdr2.net         *   
 *    skype  : zhuoql                  *   
 *    gtalk  : killy.draw@gmail.com    *   
 ***************************************/