On Wed, Feb 8, 2012 at 6:01 AM, Juan Jose Garcia-Ripoll
I'm looking at trying to get matlisp to run with ecl, and now that
someone has contributed an ffi using cffi, I thought getting matlisp
working with ecl would be nice.

That would indeed be very nice.

FYI: matlisp will now compile and run with ecl.  I only did a couple of simple tests with 32-bit ecl 11.1.x, but they worked.  I still need to incorporate some changes like with-float-traps-masked, but it looks like the basic functionality is there.  More testing is needed though.

Ray