On Sat, Aug 25, 2012 at 3:58 AM, Juan Jose Garcia-Ripoll <juanjose.garciaripoll@gmail.com> wrote:
On Fri, Aug 17, 2012 at 2:21 PM, bob <bobatnet@gmail.com> wrote:
I am trying to build ecl (both stable from git) on MinGW (latest stable) with gcc 4.7.0. But I am presented with different errors during the make stage. Using the stable release (12.7.1) I hit upon make error while building libsocket. So I tried configure with --with-tcp=no. But then I have error in /src/c/file.d.

I reckon from your private email that you were configuring with a C++ compiler. That uncovered certain problems with some windows function prototypes and the gcc compiler being less permissive about pointer coercion. I fixed all problems in the sockets library and find no further problems in file.d. So the message is that now ECL seems to build fine in Mingw + C++

I git pull'ed the latest ECL but these configure flags didn't work:  --with-sse=yes --with-cxx=yes. It had problems compiling libffi. So I tried to compile without dffi with this:

./configure --prefix=/c/lisp/ecl-gcc --with-cxx=yes --with-sse=yes --with-dffi=no

and it worked! Thanks!

bob