Delete the ~/.slime directory. I tried rebuilding Slime today and it worked without problems.


On Wed, Jan 19, 2011 at 5:36 PM, Anton Vodonosov <> wrote:

I just installed the ecl 11.1.1 release (Windows installer from sourceforge).

When I load swank-loader.lisp (todays SLIME from CVS), I have the following error:

;;; Loading "C:/Users/anton/unpacked/lisp-libs/slime-current/slime-2011-01-19/swank-loader.lisp"
;;; Compiling C:/Users/anton/unpacked/lisp-libs/slime-current/slime-2011-01-19/swank-backend.lisp;;
;; Error while compiling C:/Users/anton/unpacked/lisp-libs/slime-current/slime-2011-01-19/swank-backend.lisp:
;;   Cannot print object #<SWANK-BACKEND package> readably.
;; Aborting.

Restart ABORT is not active.

Available restarts:

1. (RESTART-TOPLEVEL) Go back to Top-Level REPL.

 File: #P"C:/Users/anton/unpacked/lisp-libs/slime-current/slime-2011-01-19/swank-loader.lisp" (Position #5576)

Has anyone experienced this problem and know how to solve it?

Best regards,
- Anton

Protect Your Site and Customers from Malware Attacks
Learn about various malware tactics and how to avoid them. Understand
malware threats, the impact they can have on your business, and how you
can protect your company and customers by using code signing.
Ecls-list mailing list

Instituto de Física Fundamental, CSIC
c/ Serrano, 113b, Madrid 28006 (Spain)