Robin Lee Powell wrote:
On Sat, Aug 02, 2008 at 03:36:17PM +0200, Juan Jose Garcia-Ripoll wrote:
  
On Sat, Aug 2, 2008 at 1:07 AM, Robin Lee Powell
<rlpowell@digitalkingdom.org> wrote:
    
Then it did this: [...]
../../src/c/file.d(49) : fatal error C1021: invalid preprocessor command 'defien'
      
I have just upgraded the MSVC port to fix the following problems:

- A typo in file.d
- MSVC does not have the C99 macro isfinite()
- Using "nmake clean" left some files behind
- The compiler farms were actually _not_ using ECL_THREADS=1

When the compiler farm failed to build a windows port, it did not
reflect in the logs. That cause the previous problems to survive
for a few days without being detected.
    

It works great with msvc now, thank you!

I'm trying to build CLOCC now, and I'm really not sure what to do
with this error:

Type :h for Help.  Top level.
  
(in-package :cl-user)
    
#<"COMMON-LISP-USER" package>
  
(setq *clocc-root* ".\\")
    
".\\"
  
(compile-file (concatenate 'string *clocc-root* "clocc"))
    
;;; Loading #P"C:/Documents and Settings/rpowell.LOOKSMART_SF/Desktop/cygwin/ecl
/ecl/msvc/package/cmp.fas"
;;; Loading #P"C:/Documents and Settings/rpowell.LOOKSMART_SF/Desktop/cygwin/ecl
/ecl/msvc/package/sysfun.lsp"
;;; Compiling clocc.
;;; Compiling (DEFVAR *CLOCC-ROOT* ...).
;;; End of Pass 1.
;;; Note: Replacing variable G130 by its value
;;; Calling the C compiler...
;;; Note: Invoking external command:
;;; cl  /MD /EHsc /DGC_DLL /nologo  -O2 -I"C:/Documents and Settings/rpowell.LOO
KSMART_SF/Desktop/cygwin/ecl/ecl/msvc/package/" -w -c "C:/Documents and Settings
/rpowell.LOOKSMART_SF/Desktop/cygwin/tui/clocc/clocc.c" -Fo"C:/Documents and Set
tings/rpowell.LOOKSMART_SF/Desktop/cygwin/tui/clocc/clocc.obj"
clocc.c
;;; Note: Invoking external command:
;;; cl -Fe"C:/Documents and Settings/rpowell.LOOKSMART_SF/Desktop/cygwin/tui/clo
cc/clocc.fas" "C:/Documents and Settings/rpowell.LOOKSMART_SF/Desktop/cygwin/tui
/clocc/clocc.obj"  /LD /MD /link /nologo /nodefaultlib:libcmt /nodefaultlib:libc
mtd /nodefaultlib:libc /nodefaultlib:libd ecl.lib user32.lib ws2_32.lib shell32.
lib /EXPORT:init_fas_CODE /LIBPATH:C:/Documents and Settings/rpowell.LOOKSMART_S
F/Desktop/cygwin/ecl/ecl/msvc/package/
LINK : fatal error LNK1181: cannot open input file 'ecl.lib'
;;; The C compiler failed to compile the intermediate file.
Filesystem error with pathname #P"C:/Documents and Settings/rpowell.LOOKSMART_SF
/Desktop/cygwin/tui/clocc/clocc.fas".
Either
 1) the file does not exist, or
 2) we are not allow to access the file, or
 3) the pathname points to a broken symbolic link.
Broken at SI:BYTECODES.No restarts available.
Broken at SI:BYTECODES.
  

I don't know why it's trying to get ecl.lib rather than ecl.dll;
like I said, I don't know anything about linking on windows.

-Robin

  
You need to tell msvc compiler where to find the ecl.lib file. Set your environment before you start ECL as: set LIB=/path/to/your/ecl