Juan Jose Garcia-Ripoll wrote:
On Mon, Mar 17, 2008 at 2:13 AM, Jeff Cunningham <jeffrey@cunningham.net> wrote:
  
 I thought I'd try to build ECLS on an ARM9 just for the fun of it. It
 ran configure without errors but then died immediately on make. Here's
 the error:
 make[2]: Entering directory `/home/jcunningham/installed/ecl-0.9j/build/gmp'
 make[2]: *** No rule to make target `install'.  Stop.
    

Could you please enter directory ec/build/gmp and try running "make"?
It may well be that the GNU mp library does not support your system.
If this is the case, one can always convince it to build the C
version, which is slower but works everywhere.

Juanjo

  
I don't seem to have a Makefile in build/gmp. Here are all the Makefiles built by configure:

jcunningham@ts7200:~/installed/ecl-0.9j$ find . -name Makefile
./src/gc/Makefile
./msvc/c/Makefile
./msvc/gc/Makefile
./msvc/doc/Makefile
./msvc/gmp/Makefile
./msvc/Makefile
./Makefile
./build/c/Makefile
./build/gc/doc/Makefile
./build/gc/Makefile
./build/gc/include/Makefile
./build/doc/Makefile
./build/Makefile
./examples/threads/import_win32/Makefile
./examples/threads/import/Makefile


And here is the contents of build/gmp:

jcunningham@ts7200:~/installed/ecl-0.9j$ ll build/gmp
total 548
-rw-r--r-- 1 jcunningham jcunningham    133 Mar 16 17:49 cnfm4.tmp
-rw-r--r-- 1 jcunningham jcunningham     76 Mar 16 17:49 cnfm4i.tmp
-rw-r--r-- 1 jcunningham jcunningham    148 Mar 16 17:54 cnfm4p.tmp
-rw-r--r-- 1 jcunningham jcunningham 122730 Mar 16 17:56 config.log
-rw-r--r-- 1 jcunningham jcunningham  82536 Mar 16 17:50 gmp-h.in
-rw-r--r-- 1 jcunningham jcunningham 141889 Mar 16 17:50 gmp-impl.h
-rwxr-xr-x 1 jcunningham jcunningham 194711 Mar 16 17:52 libtool


--Jeff