Hi,

I have decided to adopt ECL as my Lisp. I tend to use Windows exclusively. I have downloaded the latest version of ECLS and tried following the instructions for installing and making but with no luck so far. Information and problems I have noticed:

1. I use pure windows - no cygwin etc.
2. I can only use the free versions of C++
3. The instructions for installing on Windows seem to be outdated as there are newer versions of the SDK, C++ compiler,  .NET framework and .NET SDK.
4. The .NET SDK requires a prior install of software - no mention is made of this.
5. The MAKEFILE has latest software as 0.9h although it is 0.9i now.
6. The links provided by ECLS in the install.html file and on the website appear to be outdated.
7. Mention is made of copying libraries from the the .NET SDK to the C++ directories - but these libraries already exist in the C++ lib directory and have a more recent timestamp and different sizes.
8. The NMAKE file pointed to doesn't seem to install to a specific directory but just to the current directory - also a newer NMAKE.exe already exists in the free version of C++

I tried as many combinations as I could - for example older NMAKE with older libraries and other combinations but I don't have a clue as to why I am doing the things I am!

I would be more than happy to update the documentation etc. once I can get my system working and understand better what I am trying to do, but looks like I need lots of help getting there!