Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Lesson 6 video - my Rerun Test is greyed out

Tom
2011-11-15
2013-04-09
  • Tom
    Tom
    2011-11-15

    (complete beginner - pls forgive if I overlooked something really basic)

    My problem is that while following the Lesson 6 video,
    three Icons on the JUnit tab:
    - Rerun Test
    - Rerun Test - Failures First, and
    - Stop JUnit Test Run
    have become *greyed out*.

    Erasing and re-entering text in *.java files doesn't
    make the Rerun Test button active.

    I've followed all video tutorials to the end of Lesson 6.
    To that point, all *other* directions worked as described,
    or with such slight differences that my Eclipse version (3.7.1)
    gave no difficulties.

    Moreover, Lesson 6 followed on from code that I'd already
    begun entering and had working (including "Rerun Test")
    in Lesson 5. I can't figure what I've done differently.

    Before starting the Lessons, I'd installed Eclipse Classic SDK Version: 3.7.1
    plus modules from the "Indigo" Eclipse packages for
    - Java EE Developer Tools
    - Java web Developer Tools
    - Java EE Developer Tools
    and I ran through all the Workbench tutorials.

     
  • Tom
    Tom
    2011-11-15

    Mark please delete this and my post above:
    I finally tripped over the Run command in the Run menu
    and until I used that I couldn't use RE-run on the JUnit tab.

    And thanx heaps for such a comprehensive and well designed set of tutorials :)

     
  • stoner1916
    stoner1916
    2012-03-09

    Please don't remove this thread. I had the exact same problem, stakk77 you are not alone, leaving this here addressed the issue for me. Also would like to add my thanks to Mark.