Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Code completion

Help
2009-07-14
2013-04-29
  • Hi, I've installed sqlexplorer_plugin-3.5.0.RC8. After checking the box "Tables and columns auto-completion" in Preferences the "Loading Content Assist" started. After finishing I tried to hit  Cntl + Space but nothing happens :-) Can you please help me? Thank you

     
    • Heiko Hilbert
      Heiko Hilbert
      2009-07-19

      Code completion starts only if you have entered at leats one character so try to input
      'sel' and the hit Ctrl+Space and 'select' should be suggested.
      Or input the first letters of a tabel name and then hit Ctrl+Space.
      You can also complete alias names, so if you have a statement like
      select t.* from MY_TABLE as t
      You can put the input cursor behind t. and hit Ctrl+Space to get a list of all collumn names of table MY_TABLE.
      If all these don't work. Check your error log, please.

       
  • Davyd McColl
    Davyd McColl
    2010-02-03

    I have the latest 3.5.1 download (full, with jre) and I'm having similar problems.

    If I type "sel" and hit ctrl-Enter, I'm offered "select" and "selection" for choices. Fine. SQLExplorer also completes words like "from". But despite seeing a long process of "Loading Content Assist" happening at first login, I can't get completions for any of my tables or procedures. To be honest, completion on words like "select" and "from" is nowhere near as useful as completion for tables, columns and procedures. I must be missing something… I would appreciate any help.

     
  • Heiko Hilbert
    Heiko Hilbert
    2010-02-06

    Content Assist is one point that should be improved in SE. Nevertheless if SE was able to query your databse structure it offers completion for table and column names too.
    Can you see your tables and columns in the database view?
    Did you find any errors in the error log caused by SQLExplorer?
    Which database and JDBC Driver do you use?

     

  • Anonymous
    2010-04-20

    When working on Oracle db, the only way I see my tables is if I start typing the ownername then I get the whole list prefixed with the owner name. It works, but it is cumbersome. Could be that you are running into the same issue when hitting ctrl-space and not getting anything?

     

  • Anonymous
    2011-02-07

    Hi.
    I am using Microsoft's native jdbc driver with Eclipse 3.5.1. I don't get any content assist at all in the SQL Editor. I have enabled content assist in the preferences, and when I establish a new connection to the database I can see that SQL Editor loads the database schema. However, if I type something like "select * from mytable t where t." then type ctrl-space or ctrl-enter, nothing happens. I've tried "select * from dbo." + ctrl-space or ctrl-enter, still don't see anything pop up.

    In other words, content assist appears to be broken in version 3.6.1.v20101117