Results truncated

Help
bawcior
2012-04-10
2013-04-29
  • bawcior
    bawcior
    2012-04-10

    Hi, I am running an Oracle query that retrieves about 800 results. One of the columns contains very large number of characters (over 30,000). I noticed that results window truncates that column and only displays fixed number of characters. I am exporting the results then to XLS file so that I can retrieve certain information that's located almost at the bottom of the column that has large number of characters. However, the exported results are truncated as well. I am using the standalone version of SQL Explorer. How can I configure it so that it doesn't truncate the results (I want to see all characters). I saw an option of number of characters for batch mode, but that doesn't make a difference and I don't know how this batch mode works. Any help would be appreciated. Thank you

     
  • Heiko Hilbert
    Heiko Hilbert
    2012-04-11

    Hi,
    I have no Oracel databse to reproduce that problem, but I think this is a problem with JDBC type LONGVARCHAR.
    The JDBC documentation says:

    The method ResultSet.getString, which allocates and returns a new String object, is recommended for retrieving data from CHAR, VARCHAR, and LONGVARCHAR fields. This is suitable for retrieving normal data, but can be unwieldy if the JDBC type LONGVARCHAR is being used to store multi-megabyte strings. To handle this case, two methods in the ResultSet interface allow programmers to retrieve a LONGVARCHAR value as a Java input stream from which they can subsequently read data in whatever size chunks they prefer. These methods are getAsciiStream and getCharacterStream, which deliver the data stored in a LONGVARCHAR column as a stream of ASCII or Unicode characters. Note that the method getUnicodeStream has been deprecated.

    But 30.000 characters are not multi-megabytes. I can add the special handling for LONGVARCHAR type.
    Could you check the documentation of your Oracle JDBC-Driver, perhpas there is an URL parameter which controls the max length returned for strings.

     
  • Heiko Hilbert
    Heiko Hilbert
    2012-04-12

    Should be fixed with new SR5 release today. In the Results preference you can set the max length of BLOB data to 0 to get all data.