SQLExplorer + UTF-8

patrice
2007-09-18
2013-04-29
  • patrice
    patrice
    2007-09-18

    I try to insert, via SQL Explorer, UTF-8 characters (simplified Chinese) into my Sybase database. I I cannot make it but I can read UTF-8.
    How do I have to configure SQL Explorer ?

    Thanks

     
    • spackers
      spackers
      2007-09-18

      Hi Patrice,

      I _think_ that this will be a generic Eclipse issue because SQLExplorer uses the Eclipse-provided text editor; I've found the following page which appears to address the issue:

         http://www.eclipsezone.com/eclipse/forums/t93442.rhtml

      Also found the following on http://www.compoundtheory.com/?action=displayCategory&ID=8

         Much thanks to Rob from CFEclipse for pointing this out for me.
         Eclipse by default does not support Unicode / UTF-8.
         Turning it on, is very easy if you know where it is.
         Goto: Window > Preferences > Workbench > Editors

         At the bottom of that screen you can see 'Text file encoding'. Just choose the relevent one
         (choices range from US-ASCII to UTF-8), click the one you want, and presto, away you go.

         Then just reopen the UTF-8 file you had, and presto - Unicode Support!

      Please let me what you find out.

      Thanks,
      John

       
      • patrice
        patrice
        2007-09-19

        Hello John,

        I have already done that configuration but it doesnt work.
        I use the version "SQl Explorer RCP" and i have done the configuration in
        File > Preferences > Workspace.
        I can read simplified chinese but not insert simplified chinese.

        Thanks for your help.

        Patrice.

         
    • spackers
      spackers
      2007-09-19

      Hi Patrice,

      Please can you email me an attachment (to spackers@users.sourceforge.net) with a file I can use to try copy & paste with?  Please also include any notes I'll need to access the file normally, eg Windows config, special version of Windows, etc and I'll try and sort it out.

      Cheers,
      John