How to install the plugin

VV22
2009-06-23
2013-08-22
  • VV22
    VV22
    2009-06-23

    Hi,

    Can someone tell me how to install the plug-in? I tried placing the jar file in the plugins directory and it has no effect. Is there any documentation on how to install the plugin?

    Thanks a lot.

     
    • Matt Garner
      Matt Garner
      2009-06-24

      Hope this helps. Sorry I've not got round to adding a decent installation and user guide.

      Cheers,
      Matt.

      Installation

      Plugin Requirements
      Eclipse 3.4
      Java 1.6

      To install the plugin from the zip archive file:

      1) Download the latest zip archive from the sourceforge website.
      2) In Eclipse, Navigate to Help->Software Updates
      3) Select Available Software Tab.
      4) Click Add Site and then Archive.
      5) Select the zip file from the repository file dialog.
      6) From the newly added site, tick the Json Editor Plugin.
      7) Click the Install button in the top right hand corner.
      8) Choose to install the plugin.
      9) Eclipse will need to be restarted after the plugin installation.

      To install the plugin from the update site:

      1) In Eclipse, Navigate to Help->Software Updates
      2) Select Available Software tab.
      3) Click Add Site and then paste in the url -
      http://eclipsejsonedit.svn.sourceforge.net/viewvc/eclipsejsonedit/trunk/Json%20Editor%20Plugin
      4) From the newly added site, tick the Json Editor Plugin
      5) Click the Install button in the top right hand corner.
      6) Choose to install the Json Editor Plugin
      7) Eclipse will need to be restarted after the plugin installation.

       
      • Martin Kuhn
        Martin Kuhn
        2009-07-23

        Yes, thanky you

         
    • bharani0522
      bharani0522
      2009-07-23

      When I tried to install the plugin, it gives me an error: "Json Editor Plugin (0.9.3) does not have a valid license agreement." And I cant install the plugin. Please help me.

       
    • Matt Garner
      Matt Garner
      2009-07-23

      Hi bharani0522,

      Thanks for your mail. Sorry you couldn't install the plugin. This is due to you using the classic Eclipse installer. This requires some license text.

      I've fixed this issue. You should either download the plugin zip file again or use the update site URL.

      Let me know if you have any further issues.

      Cheers,
      Matt.

       
      • bharani0522
        bharani0522
        2009-07-23

        Thankyou Matt. I downloaded the plugin again and still getting the same issue. :(

         
        • bharani0522
          bharani0522
          2009-07-23

          Matt, I have installed the plugin somehow. But getting this error: "Plug-in json.editor.plugin was unable to instantiate class json.prefs.WorkbenchPreferencePage: NullPointerException"

           
          • Matt Garner
            Matt Garner
            2009-07-23

            Hi bharani,

            Which version of eclipse are you using? Seems a strange error. Do you have any more info.

            Cheers,
            Matt.

             
    • bharani0522
      bharani0522
      2009-07-23

      Hi Matt,
      Its Version: 3.2.2
      Build id: M20070212-1330

       
    • Matt Garner
      Matt Garner
      2009-07-23

      Ah sorry, unfortunately you need Eclipse version 3.4 or newer to use the plugin.

      Cheers,
      Matt.

       
  • polakkiioo
    polakkiioo
    2010-04-09

    With a Ganymade and it's works.
    However, I tried to install in the Galileo version but seems that it's not
    working.
    I did up to the step 5, but then it looks that it is not recognize an item to
    install.

     
  • Matisse Enzer
    Matisse Enzer
    2010-05-21

    I was able to install it by unpacking the zip archive and placing the
    resulting directory (

    JsonEditorPlugin-0
    

    ) inside the

    eclipse/dropins/
    

    directory.

     
  • pfuerholz
    pfuerholz
    2010-07-17

    With Eclipse Galileo (3.5.2) I constantly get following error:
    An error occurred while installing the items
    session context was:(profile=PlatformProfile,
    phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Install,
    operand=null --> org.eclipse.pde 3.4.100.v201002111343, action=org.eclipse.equ
    inox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
    The artifact file for osgi.bundle,org.eclipse.pde,3.4.100.v201002111343 was
    not found.

    Tried installing from zip and via Internet.

    (@Matisse: Can't following your advice, I don't find an eclipse/dropins
    directory in my filesystem...)

    Thanks,
    Peter

     
  • chul kang
    chul kang
    2011-10-25

    after adding zip file, you need to unchecked 'Group items by category '..

     

  • Anonymous
    2012-01-10

    Replacing the %20 with spaces each time Eclipse tried to use %20 worked for me
    too

     
  • Pascal
    Pascal
    2012-02-01

    Hello I got the same problem, eclipse told me that "There are no categorized
    items" I work on Eclipse 3.7, Indigo..
    Thank for your help

     
  • Hello. With eclipse 3.6 I have the same problem.
    There are no categorized items

     
  • Chemik
    Chemik
    2012-02-13

    Uncheck "Group items by category" to show installable item.

     
  • dev4u
    dev4u
    2012-06-28

    Thanks @chemco

     
  • Feras
    Feras
    2012-07-24

    Uncheck "Group items by category" solved issue on eclipse 3.8