Dev Team,

Hopefully this is a simple question, but what platforms have been tested with the released version of 2.2.0?  (I last used a working version during the spring on Ubuntu.)

Reason I ask is that I've been having issues with getting scion-browser to compile properly.  Trying two different platforms with Eclipse 3.7, MacOS X w/ GHC 7.2.1 (tried 7.0.X) and Ubuntu 11.10 w/ Eclipse 3.7 and (both what's included and what's downloadable).  I'm wondering if there's a specific order I need to run the packages with cabal, or if I'm missing something that needs to be installed.

[19 of 22] Compiling Scion.Hoogle.Parser ( src/Scion/Hoogle/Parser.hs, dist/build/scion-browser/scion-browser-tmp/Scion/Hoogle/Parser.o )
[20 of 22] Compiling Scion.Hoogle     ( src/Scion/Hoogle.hs, dist/build/scion-browser/scion-browser-tmp/Scion/Hoogle.o )

src/Scion/Hoogle.hs:8:1:
    Warning: The import of `Data.ByteString.Char8' is redundant
               except perhaps to import instances from `Data.ByteString.Char8'
             To import instances alone, use: import Data.ByteString.Char8()
[21 of 22] Compiling Server.Commands  ( src/Server/Commands.hs, dist/build/scion-browser/scion-browser-tmp/Server/Commands.o )
[22 of 22] Compiling Main             ( src/Main.hs, dist/build/scion-browser/scion-browser-tmp/Main.o )

src/Main.hs:22:17: Not in scope: data constructor `Atto.Fail'

src/Main.hs:23:17: Not in scope: data constructor `Atto.Done'
cabal: Error: some packages failed to install:
scion-browser-0.1.3.2 failed during the building phase. The exception was:
ExitFailure 1

thanks
evan