Permission Denied

Help
Anonymous
2012-11-02
2012-12-06

  • Anonymous
    2012-11-02

    Hi all,

    trying to install EclipseFP on OS X Mountain Lion but the installation fails with

    Installing library in
    /Users/Salman/Library/Haskell/ghc-7.4.1/lib/xml-1.3.12/lib
    Registering xml-1.3.12…
    Downloading texmath-0.6.1.1…
    Downloading zip-archive-0.1.2.1…
    Updating documentation index /Users/Salman/Library/Haskell/doc/index.html
    cabal: /Users/Salman/Library/Haskell/doc/tmphaddock-13738: permission denied

    Any suggestions?

    Thanks

     

  • Anonymous
    2012-11-02

    The error message changed fter I re-installed Eclipse and Haskell. Apparently, it can't install utf8-string but I don't understand what is going on:

    Documentation created: dist/doc/html/xml/index.html
    sudo: no tty present and no askpass program specified
    cabal: Error: some packages failed to install:
    Graphalyze-0.13.0.1 depends on xml-1.3.12 which failed to install.
    List-0.4.4 failed during the final install step. The exception was:
    ExitFailure 1
    SourceGraph-0.7.0.3 depends on xml-1.3.12 which failed to install.
    base64-bytestring-1.0.0.0 failed during the final install step. The exception
    was:
    ExitFailure 1
    bktrees-0.3.1 failed during the final install step. The exception was:
    ExitFailure 1
    blaze-builder-0.3.1.0 failed during the final install step. The exception was:
    ExitFailure 1
    blaze-html-0.4.3.4 depends on blaze-builder-0.3.1.0 which failed to install.
    citeproc-hs-0.3.6 depends on utf8-string-0.3.7 which failed to install.
    colour-2.3.3 failed during the final install step. The exception was:
    ExitFailure 1
    cpphs-1.14 failed during the final install step. The exception was:
    ExitFailure 1
    digest-0.0.1.1 failed during the final install step. The exception was:
    ExitFailure 1
    dlist-0.5 failed during the final install step. The exception was:
    ExitFailure 1
    graphviz-2999.14.1.0 depends on wl-pprint-text-1.1.0.0 which failed to
    install.
    haskell-src-exts-1.13.5 depends on cpphs-1.14 which failed to install.
    hexpat-0.20.2 depends on utf8-string-0.3.7 which failed to install.
    highlighting-kate-0.5.3.3 depends on regex-pcre-builtin-0.94.2.1.7.7 which
    failed to install.
    hs-bibutils-4.15 failed during the final install step. The exception was:
    ExitFailure 1
    json-0.7 failed during the final install step. The exception was:
    ExitFailure 1
    multiset-0.2.1 failed during the final install step. The exception was:
    ExitFailure 1
    pandoc-1.9.4.5 depends on xml-1.3.12 which failed to install.
    pandoc-types-1.9.1 failed during the final install step. The exception was:
    ExitFailure 1
    polyparse-1.8 failed during the final install step. The exception was:
    ExitFailure 1
    regex-pcre-builtin-0.94.2.1.7.7 failed during the final install step. The
    exception was:
    ExitFailure 1
    tagsoup-0.12.8 failed during the final install step. The exception was:
    ExitFailure 1
    temporary-1.1.2.4 failed during the final install step. The exception was:
    ExitFailure 1
    texmath-0.6.1.1 depends on xml-1.3.12 which failed to install.
    utf8-string-0.3.7 failed during the final install step. The exception was:
    ExitFailure 1
    wl-pprint-text-1.1.0.0 failed during the final install step. The exception
    was:
    ExitFailure 1
    xml-1.3.12 failed during the final install step. The exception was:
    ExitFailure 1
    zip-archive-0.1.2.1 depends on utf8-string-0.3.7 which failed to install.

    Thanks

     
  • JP Moresmau
    JP Moresmau
    2012-11-04

    Try installing one of the failing libraries with -verbose, maybe you'll get clearer messages. But it does seem that you don't have the permissions to all the folders needed by Cabal.
    sudo: no tty present and no askpass program specified
    That's not a good sign…