No pyUML buttons

Help
2008-09-11
2013-04-16
  • alex_munich
    alex_munich
    2008-09-11

    Hallo Martin,

    ich habe heute "Eclipse IDE for Java Developers (85 MB)" unter

    "http://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/ganymede/R/eclipse-java-ganymede-win32.zip"

    für Window installiert.

    Danach habe ich aus "PyUML-1.0-all-plugins" die entsprechenden Unterverzeichnisse in die gleichnamigen Eclipse Verzeichnisse kopiert.

    Nach dem Start von Eclipse kann ich keine Änderung feststellen.

    So ist bspw. unter "Window→Preferences→UML Class Diagram" kein entsprechender Eintrag.

    Interessanterweise läuft jedoch nach dem Umkopieren pydev. Irgendwie scheint dein Plugin nicht geladen zu werden.

    Muss ggf. noch etwas in Eclipse konfigieriert werden?

    Viele Grüße aus München
    Alex

     
    • Martin Dittmar
      Martin Dittmar
      2008-09-15

      Hallo Alex,

      sorry für die späte Antwort!
      Das Problem ist leider, dass eclipse-pyuml nicht mit Eclipse 3.4 zusammenarbeitet, da für die Live-Validierung ein Teil von GMF geändert werden musste.

      Wenn du es verwenden willst, musst du leider Eclipse 3.3.1 oder 3.3.2 verwenden.
      Wenn du willst, könnte ich auch mal ein komplettes Eclipse-Paket inkl. pyUML hochladen.

      Ich werde die Abhängigkeit bei Gelegenheit mal ändern, bzw. Live Validation abschalten....

      Sorry für die aktuellen Umstände und viel Spaß noch mit eclipse-pyUML!

      Gruß, Martin

       
    • alex_munich
      alex_munich
      2008-09-15

      Hallo Martin,

      danke für die Antwort. Ich habe mir folgende Version von Eclipse (für Windows) installiert: Eclipse SDK, Version: 3.3.2, Build id: M20080221-1800

      Dann habe ich die All-Plugin Verzeichnisse an die entsprechende Stelle im Eclipseverzeichnis kopiert.

      Das Plug-In ist immer noch nicht da?!?!
      Wenn ich in Help->About Eclipse SDK->Plugi-In Details reinschaue, dann sehe ich bspw. die pydev-Plugins.

      Wie heisst Dein Plugin?

      Vielleicht kannst Du Deine vollständige Eclipse Umgebung hochladen. Dann kann ich probieren, ob es an der unterschiedlichen Eclipse-Umgebung liegt
      (vielleicht braucht PyUML auch eine andere JAVA SDK Fassung oder eine andere Python-Version, andere Pfade etc?!?).

      Viele Grüße
      Alex

       
      • Martin Dittmar
        Martin Dittmar
        2008-09-19

        Hallo Alex,

        was mir noch dazu einfällt: Hast du wirklich Eclipse 3.3.2 für Java-Developers verwendet? Mit der allumfassenden Version geht's leider nicht...

        Ich werde die nächsten Tage mal eine Komplettversion für Windows und Linux hochladen, dann kann man sicher sein, dass es klappt...

        Sorry für die Umstande,

        Gruß Maritn

         
        • alex_munich
          alex_munich
          2008-09-20

          Hallo Martin,

          eigentlich müsste ich die richtige Eclipse-Version haben.

          Daher vermute ich jetzt auch, dass die falsche Eclipse-Version nicht die Fehlerursache ist. Das klärt sich aber sofort, wenn ich Deine Komplettversion testen kann. Wenn die auch nicht läuft, dann liegt es nicht an Eclipse :-)

          Mach Dir aber keinen Stress,da ich die nächsten Wochen ohnehin im Urlaub bin.

          Da ich Python, Eclipse und UML mag, finde ich pyUML eine super Idee. Ohne UML verliert man meiner Meinung nach in komplexeren objektorientierte Strukturen irgendwann den Überblick. Aber die separate Pflege von Source und Modell hält man auf Dauer auch nicht durch.

          Ich kann mir auch gut vorstellen, dass andere Entwickler pyUML gut gebrauchen könnten.

          Viele Grüße
          Alexander