Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

PyUML not functioning properly

2010-03-04
2013-04-16
  • Marvin Offiah
    Marvin Offiah
    2010-03-04

    Hello,

    according to your manuals, I am just to create a PyDev project, and a PyUML diagram will automaticaly be created.
    Nothing of this happens.
    When I create a PyUML class diagram within my source or project folder myself and click the snake symbol, no python files are created.

    I thought PyUML with PyDev is able to generate python code from UML code? Why isn't this working?

    Thanks in advace

     
  • Marvin Offiah
    Marvin Offiah
    2010-03-05

    Hmm…anyone?

    I'm sorry, I've already tried several solutions for creating Python code from UML in Eclipse, none seems to work.

     
  • Marvin Offiah
    Marvin Offiah
    2010-03-06

    Please, I have read and followed your manual, it just doesn't work, the snake button doesn't do anything at all.

     
  • Marvin Offiah
    Marvin Offiah
    2010-03-06

    Ahh…no problem. Got it to work now.

    Looks like PyDev doesn't create the PyUML folder on its own, really need to specify the creation of the model folder manually, and by the left PyUML button only, not creating it yourself via package explorer.

    Just for anyone who might need to know.

     
  •  mgfor
    mgfor
    2010-04-08

    Hi,
    I also have problems with pyUML. I even can not see the Plugin-Icons
    The Update-Manager link did not work, thus I downloaded the plugin (without pydev, because it is already integrated in my eclipse).
    I copied the content of the folders to plugins and features in eclipse. Restart.
    No changes. Did I miss anything else?
    Thanks for help.