Unable to checkout imported resources

Help
Anonymous
2011-07-21
2013-04-06

  • Anonymous
    2011-07-21

    There are not any project files in the clearcase setup I am using. Can I still checkin/checkout? I have

    • Installed Eclipse 3.6

    • Created dummy project and imported File System from my local snapshot view

    • Associated the project with clearcase

    • Verified that I can check out/in from Clearcase Explorer and cmd

    I am using Windows 7 64bit. Eclipse 3.6 and the newest version your plugin.

     

  • Anonymous
    2011-07-21

    Probably should have actually added my problem :)

    When I right click on a file, the options to checkin/out are greyed out. I can view my config_spec though, and it is the same as the one I entered when I created the view.

     
  • Hi Matt,

    I think that you need a project file to be able to ci/co files. Try to make a project for the files that you want to work with. Is a java or c++ project? I have limted internet access this week but I will try to answer asap.

    br,

    //mike

     

  • Anonymous
    2011-07-25

    So I made a Java project (the code is both java and c++…) and imported a "File System" (my local snapshot of the Clearcase view). I then associated the project with ClearCase. I can view the files fine, but when I click "Checkout", I receive:

    cleartool: Error: Type must be mastered in original replica "<LOCATION>" to use copy type.
    cleartool: Error: Unable to create branch requested by -mkbranch option in config spec.
    cleartool: Error: Unable to check out "<FILENAME>".

     
  • Hi Matt,

    I don't have access to your config spec but I think I have an idea. If you check this link:

    http://www.ipnom.com/ClearCase-Commands/checkout.html check

    Under heading MultiSite: Checking Out a Branch Mastered at Another Site.

    I I don't remember incorrect we have an option under Preferences -> Team -> ClearCase I think you can add the option -nmaster for checkout. Also make sure the checkout is unreserved.

    Please let me know if this option works for you.

    br,

    //mike

     
  • Matt
    Matt
    2011-07-25

    The options were already set (Reserved -> Never; "User -master flag when adding resource" -> Checked).

    Same error.

    I tried playing around with the settings, but none seemed to work. Here is part of my config spec:

    element * CHECKEDOUT
    element …/lost+found -none
    element …/LATEST -nocheckout
    element * …/<USERNAME>_test_view_<DATE>/LATEST
    mkbranch <USERNAME>_IDE_TEST
    element * DV<VERSION>

    … Lots of element stuffs …

    end mkbranch

    … Lots of load stuffs …

     
  • Hi,

    Can you send the log file from eclipse workspace under .metadata/.log?
    Please attach it here.

    br,

    //mike

     

  • Anonymous
    2011-08-08

    Got your email. Success! It appears after a weekend off and updating my snapshot view, things seemed to work themselves out. Now I'm using CC and Eclipse. Sorry for the lack of details in my solution, but I really didn't change anything…

    Thanks a million for your help!

    -Matt

     

  • Anonymous
    2011-08-08

    Actually, I tried it again but this time imported while linking to the snapshot files and it didn't work. When I import and copy the files from the snapshot to the workspace, it works.

     
  • Hi,

    Glad to hear that it works now.Could you please tell me step by step ( using Eclipse menus) how you import and copy files.
    I think we need to make that description available for all.

    br,

    //mike