Java 7 -XX:-UseSplitVerifier


  • Anonymous

    I have tried using jacoco with surefire-plugin with the vm argument -XX:-UseSplitVerifier for jibx binding to work with the test cases. But jacoco does not work with this vm argument and there are no coverage reports.

    It works without the vm argument though. Anybody have any ideas?

    Appreciate your help !

  • What is the exact error mesage you get?

    Two remarks:

    The -XX:-UseSplitVerifier option only works for class file versions <= 1.6.
    We just released JaCoCo 0.5.9 which addresses an Java 7 issue in combination with the Eclipse compiler.