PPP returns error

  • pepito perez
    pepito perez

    I have installed the driver for my modem(U.S.Robotics USB ADSL Modem Dial-up connection pppoATM, ive already checked and yes, there is support for this modem)
    After having installed the modem, and having recompiled kernel 2.4.19 with support for pppoATM, HDLC, usb-uhci and usb-ohci (although it seems like usb-uhci is used and not usb-ohci)
    I have also recompiled the latest ppp(with support for ATM) together with my kernel , and installed the LATEST LIB-USB libraries, as well as configured all the files necessary for the ppp-connections to work.
    Everything seems to work when I run eci-doctor.sh, until I get the following error:

    Connect: ppp0 <--> /dev/pts/1
    Using vpi.vci=1.32
    Script /usr/local/bin/pppoeci -v 1 -vpi 1 -vci 32 finished (pid 2649), status = 0xff00
    Modem hangup
    Connection terminated.
    PPP: very bad ... usermode driver just crashed
    Dec 25 21:10:26 anisotropo kernel: usb-uhci.c: ENXIO 80000200, flags 0, urb c42b51fc, burb c42b5ee0


    using channel 11
    Using vpi.vci=1.32
    ioctl(PPPIOCGFLAGS): Inappropriate ioctl for device
    Cannot make a PPP connection: Fatal
    (If i run the script I get an error, then I run it again and get a different error, although i think both mean the same)

    Looks like ppp returns 0xff00 and hangs....
    any ideas??Help is welcome ^^
    THX anyway :D