Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#68 eboard processes left

open-fixed
Felipe Bergo
None
5
2007-02-15
2004-12-02
Khanh-Dang
No

Hi, I've just seen recent activity in the CVS tree :)))

Hope my french translation (posted in the patches
section of the project page) will be soon included !

Anyway, eboard works very well for me, apart for one
thing :
Sometimes, and I haven't succeeded in finding why,
after having left eboard, there is one process that
still remain in background. When doing a "ps afx" I
often see many processes called "(eboard beeper)".

This is not very annoying, because a workaround is to
do a "killall eboard".

I am running a Linux box (distrib is Gentoo) with
kernel 2.4.27

Discussion

  • Felipe Bergo
    Felipe Bergo
    2007-01-02

    • assigned_to: nobody --> bergo
    • status: open --> open-accepted
     
  • Felipe Bergo
    Felipe Bergo
    2007-01-02

    Logged In: YES
    user_id=23863
    Originator: NO

    I'll try to reproduce the problem. Someone sent me a french translation ages ago and it was included in 1.0.0, not sure if it was yours.

     
  • Felipe Bergo
    Felipe Bergo
    2007-01-08

    • status: open-accepted --> closed-fixed
     
  • Felipe Bergo
    Felipe Bergo
    2007-01-08

    Logged In: YES
    user_id=23863
    Originator: NO

    did some changes that may fix it (for 1.0.1, to be released Jan 8 2007)

    If it still happens, open a new ticket.

     
  • Khanh-Dang
    Khanh-Dang
    2007-02-15

    • status: closed-fixed --> open-fixed
     
  • Khanh-Dang
    Khanh-Dang
    2007-02-15

    Logged In: YES
    user_id=797052
    Originator: YES

    I think the "(eboard beeper)" processes are left because the parent process crashed. I don't know why and how it could crash: an other user on my computer actually makes eboard crash and he has never told me about that. Then, a simple way to reproduce the problem is for example to run a "kill -9" on an eboard main process.

    I suggest to find a workaround, such as a way for the child processes to kill themselves when they detect they are orphans. I don't know much about programming, so I can't help, but I think this should not be that difficult.