Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

EasyEclipse for PHP - Startup error

2009-08-20
2013-04-30
  • Gerard Earley
    Gerard Earley
    2009-08-20

    I'm having problems even starting EasyEclipse for PHP 1.2.2.2.

    I get the following error every time.
    Any suggestions would be helpful.

    !SESSION 2009-08-20 08:43:29.357 -----------------------------------------------
    eclipse.buildId=M20070212-1330
    java.version=1.5.0_09
    java.vendor=Sun Microsystems Inc.
    BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_GB
    Command-line arguments:  -os win32 -ws win32 -arch x86

    !ENTRY org.eclipse.osgi 4 0 2009-08-20 08:43:30.316
    !MESSAGE Application error
    !STACK 1
    java.lang.UnsatisfiedLinkError: no swt-win32-3236 in java.library.path
        at java.lang.ClassLoader.loadLibrary(Unknown Source)
        at java.lang.Runtime.loadLibrary0(Unknown Source)
        at java.lang.System.loadLibrary(Unknown Source)
        at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
        at org.eclipse.swt.internal.win32.OS.<clinit>(OS.java:18)
        at org.eclipse.swt.widgets.Display.<clinit>(Display.java:125)
        at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:436)
        at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)
        at org.eclipse.ui.internal.ide.IDEApplication.createDisplay(IDEApplication.java:122)
        at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:75)
        at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:78)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:92)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:68)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:177)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at org.eclipse.core.launcher.Main.invokeFramework(Main.java:336)
        at org.eclipse.core.launcher.Main.basicRun(Main.java:280)
        at org.eclipse.core.launcher.Main.run(Main.java:977)
        at org.eclipse.core.launcher.Main.main(Main.java:952)

    !ENTRY org.eclipse.osgi 2 0 2009-08-20 08:43:30.426
    !MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
    !SUBENTRY 1 org.eclipse.osgi 2 0 2009-08-20 08:43:30.426
    !MESSAGE Bundle update@plugins/org.eclipse.core.filesystem.linux.x86_1.0.0.v20060603.jar [43] was not resolved.
    !SUBENTRY 1 org.eclipse.osgi 2 0 2009-08-20 08:43:30.426
    !MESSAGE Bundle update@plugins/org.eclipse.core.filesystem.macosx_1.0.0.v20060603.jar [44] was not resolved.
    !SUBENTRY 1 org.eclipse.osgi 2 0 2009-08-20 08:43:30.427
    !MESSAGE Bundle update@plugins/org.eclipse.jdt.launching.macosx_3.1.100.v20060605.jar [106] was not resolved.
    !SUBENTRY 1 org.eclipse.osgi 2 0 2009-08-20 08:43:30.427
    !MESSAGE Bundle update@plugins/org.eclipse.swt.carbon.macosx_3.2.2.v3236.jar [130] was not resolved.
    !SUBENTRY 1 org.eclipse.osgi 2 0 2009-08-20 08:43:30.427
    !MESSAGE Bundle update@plugins/org.eclipse.swt.gtk.linux.x86_3.2.2.v3236.jar [131] was not resolved.
    !SUBENTRY 1 org.eclipse.osgi 2 0 2009-08-20 08:43:30.427
    !MESSAGE Bundle update@plugins/org.eclipse.ui.carbon_3.2.0.I20060605-1400.jar [143] was not resolved.
    !SUBENTRY 1 org.eclipse.osgi 2 0 2009-08-20 08:43:30.427
    !MESSAGE Bundle update@plugins/org.eclipse.update.core.linux_3.2.0.v20060605.jar [163] was not resolved.

     
  • iccle
    iccle
    2009-10-24

    I have exactly the same error and log contents.
    The program fails to startup after installation, in addition an error dialog appears with the following contents: &quot;An error has occurred. See the log file &lt;path&gt;\workspace\.metadata\.log&quot;

     
  • iccle
    iccle
    2009-10-24

    I just found the solution, im running windows vista and had to select &quot;run as administrator&quot; in the application properties.

     
  • Matthew Gann
    Matthew Gann
    2010-04-14

    Having the same error on a Mac…doesn't prompt for Admin password.  Any idea how to continue?

     
  • Rich Urban
    Rich Urban
    2010-08-11

    I found on Vista that I had to Run as Administrator one time. Then it complains about a workspace (which it must create on the fly, because it only happened once.)