Installing Epic in Pulse Explorer Fail

Help
2010-03-05
2013-05-20
  • I'm trying to install EPIC using the Pulse Explorer for Eclipse (as I'm rather fond of sharing profiles :). When I go to install the plugin under my account, I get asked for a login into "http://e-p-i-c.sf.net".

    However, the Epic's team documentation doesn't mention anything about a login.

    Here's what I've done:

    1. Gone into Pulse and created a new profile based on Eclipse Classic.
    2. Navigated to Software, added the EPIC software site to list of public sites, and chosen to install it.
    3. Added Pulse item to profile.
    4. Run the installer.

    The error shows up while it's all downloading/installing. Login boxes start to appear for epic related components, and I don't have credentials to put in so all I can do is hit cancel. If I hit cancel, the process fails at the end with the generic error message: "an unexpected error occured preparing to install and/or launch the selected profile".

    Bundles that are failing to download are:

    * org.epic.debug
    * org.epic.doc
    * org.epic.lib
    * org.epic.perleditor
    * org.epic.regxp
    * org.epic.source

    The component that's exploding is called:
    org.eclipse.equinox.internal.p2.repository.Credentials$LoginCancelledException

    I've had the same effect on Pulse 0.5.x and 0.6.x.

    I've also posted this question on Stack Overflow as it seemed appropriate.

    Many thanks in advance :).
    ~Matthew.

     
  • I'm a bit disappointed at the lack of response to this post. However, I found the solution was to point at a different update site.

    Steps can be found on the Stack Overflow link I posted on the original post. The update site URL I'm using is:
    http://www.epic-ide.org/updates/site.xml