PadWalker-1.92 installation problem

Help
gigip
2011-05-12
2013-05-20
  • gigip
    gigip
    2011-05-12

    Environment:  ActivePerl on WinXP, Eclipse, EPIC, all behaving normal.  I tried installing PadWalker using PPM from the command (as well as the GUI). In both cases it finds the module but complains that unpacking failed (messages below). Am I doing anything wrong?

    Synchronizing Database … done
    PadWalker marked for install
    Installing package …
      Downloading PadWalker-1.92 … done
      Unpacking PadWalker-1.92 … failed

    ERROR: Can't extract files from C:\DOCUME~1\userX\LOCALS~1\Temp\ppm-Soxytd/PadWalker-1.92.tgz

    I also downloaded 1.92 and WinRAR cannot unpack it either-something must be wrong. Then I downloaded 1.91 and WinRAR unpacks it w/o errors.  How can I get PPM to install version 1.91?  I tried all kinds of things on the command line (full path, put it under perl\lib, etc) and it still complains that it cannot find a package that has it.. 

    Help, Please!!!

     
  • Jan Ploski
    Jan Ploski
    2011-05-12

    If ActiveState's version doesn't work, maybe try installing from the Bribes de Perl repository? The .tar.gz archives there seem ok.

    ppm install http://www.bribes.org/perl/ppm/PadWalker.ppd

     
  • gigip
    gigip
    2011-05-17

    Thanks for the suggestion (very quick, too…!).  I tried it and had the same problem. Then I tried on another machine at home and the whole thing worked flawlessly.  I suspect that the firewall at my workplace was corrupting the file, although I did not experiment enough to prove it conclusively.