EPIC broken!

Help
Chris
2009-03-17
2013-05-20
  • Chris
    Chris
    2009-03-17

    Hi,

    Yesterday Eclipse stopped working in that it hung every time I tried to load it. After some investigation I've found that it freezes hard whenever Eclipse tries to load a perl file with EPIC.

    I've tried a complete re-install of Ganymede 3.4.2 with EPIC stable 0.5.46 using a fresh workspace and I get exactly the same behaviour.

    Something is seriously broken in EPIC!

    Can someone advise of a fix as this is my work tool!

     
    • Jan Ploski
      Jan Ploski
      2009-03-17

      "a perl file" = "any perl file"?

       
    • Darin Burleigh
      Darin Burleigh
      2009-03-26

      I have not been able to install EPIC successfully.

      I tried installing the 0.5 update on top of my Europa ('classic', with several plugins installed), running on Windows XP. I have ActiveState Perl 5.8 installed.

      After installing, Eclipse just hangs. I can't edit any files. I can't even get to the  Update menu in order to uninstall EPIC. I tried deleted all the org.epic.* folders, but still no go.

      So, it completely hosed my current Eclipse.

      I tried installing the 0.6 release,  on a brand new Ganymede version of Eclipse ( for J2EE). This time I couldn't even complete the installation. It just hangs about halfway through.

      I have it running just fine at home on Ubuntu. So I'm assuming its broken in Windows.

       
    • Jan Ploski
      Jan Ploski
      2009-03-26

      You can try the following procedure:
      1. Close Eclipse
      2. Delete (or move away) the directory <eclipse install dir>/org.eclipse.osgi
      3. Restart Eclipse

      I just also had problems updating EPIC under Windows and it helped (although the "new and improved" P2 Update Manager does crazy things like showing EPIC update site 3 times in a row).