error while "resolving dependencies"

Help
2008-09-02
2013-05-20
  • Javier Iserte
    Javier Iserte
    2008-09-02

    i can't install epic on eclipse 3.4.
    An message error appears while installer trying to resolve dependencies. I tryed to install another version of epic and doesn't work, also i tryed to remove and re-add the repository site.
    the error message is below. Can anyone tell what is happening?

    Cannot complete the request.  See the details.
      Cannot complete the request.  See the details.
      Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.epic.regexp/[0.5.1,0.5.1]] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.epic.regexp/[0.1.4,0.1.4]] can be satisfied.
      Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.epic.regexp/[0.5.1,0.5.1]] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.epic.regexp/[0.1.4,0.1.4]] can be satisfied.
      Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.epic.regexp/[0.5.1,0.5.1]] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.epic.regexp/[0.1.4,0.1.4]] can be satisfied.
      Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.epic.regexp/[0.5.1,0.5.1]] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.epic.regexp/[0.1.4,0.1.4]] can be satisfied.
      Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.epic.regexp/[0.5.1,0.5.1]] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.epic.regexp/[0.1.4,0.1.4]] can be satisfied.
      Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.epic.regexp/[0.5.1,0.5.1]] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.epic.regexp/[0.1.4,0.1.4]] can be satisfied.

     
    • Jan Ploski
      Jan Ploski
      2008-09-02

      It seems that the new p2 update manager of Eclipse can really mess up your installation.

      Try an installation from sanitized initial conditions:
      - remove $ECLIPSE_HOME/plugins/*epic*
      - remove $ECLIPSE_HOME/features/*epic*
      - remove the update sites
      - remove lines with 'epic' from $ECLIPSE_HOME/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info

      If you're still running into problems after that, you can also try installing using the old update manager which used to be standard prior to Eclipse 3.4. It can be re-enabled under Preferences/Capabilities. However, if do it this way, you may have to add the relevant plugin entries for EPIC to the bundles.info file manually. If the entries are missing, the old update manager will complain about the org.epic.perleditor feature not being configured properly. You will see messages such as "No plug-in: "org.epic.perleditor" included at runtime" when you query the feature's status. Finally, if you install using the old manager, the new p2 manager might remain unaware of the changes. So it is advisable to retry with the new update manager after the installation with the old one has succeeded.