Debugger problem

Help
2008-06-02
2013-05-20
  • David Cuestas
    David Cuestas
    2008-06-02

    Hello, I'm trying to run the debugger, but I've got a problem, the debugger view opens, but appears a new window where is written:
    EPIC error:
    Timed out while waiting for Perl debugger connection

    Then in the Eclipse console in the debugger view appears:
    Unable to connect to remote host: 0:0:0:0:0:0:0:1:5000
    Compilation failed in require.
    Can't use an undefined value as a symbol reference at workspace/.metadata/.plugins/org.epic.debug/perl5db.pl line 7496

    Log error from eclpise:

    java.lang.Exception: Generated exception.
            at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.preFindLocalClass(EclipseLazyStarter.java:77)
            at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:412)
            at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:189)
            at org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass(BundleLoader.java:334)
            at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:386)
            at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:347)
            at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:83)
            at java.lang.ClassLoader.loadClass(Unknown Source)
            at java.lang.ClassLoader.loadClassInternal(Unknown Source)
            at net.sourceforge.phpeclipse.PHPeclipsePlugin$3.run(PHPeclipsePlugin.java:1182)
            at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)

    It's strange than in the log appears the php plugin.
    I checked that my firewall is switched off.
    and I'm working on
    fedora 6
    eclipse 3.2.2
    perl v5.8.8
    EPIC Testing: 0.6.24 (It has been download today (June 2nd, 2008))
    PadWalker-1.7

    If I try -d option with perl in a console it works.
    Can anybody help me?

    thanks in advance

     
    • Jan Ploski
      Jan Ploski
      2008-06-02

      Which version of Java? (Help/About.. in Eclipse) If you are using the gcj version, switch to Java from Sun (java.sun.com). If the problem still occurs with Sun's Java, post the contents of the debugger console (see earlier messages from this forum to find out how to enable it).

       
    • David Cuestas
      David Cuestas
      2008-06-03

      Ok, I've got java from sun version 1.6.0_02, I'm trying to run a local debug

      I followed some previous threats and nothing I found solved my problem, I normally do before posting ;P
      I'll continue searching some solution, and whenever I find it I'll post here.

      Ok,so here are the complete contents of the debugger console:

      Unable to connect to remote host: 0:0:0:0:0:0:0:1:5000
      Compilation failed in require.
      at /home/----/eclipse_workspaces/workspace2/prueba/prueba.pl line 0
          main::BEGIN() called at /home/----/eclipse_workspaces/workspace2/.metadata/.plugins/org.epic.debug/perl5db.pl line 0
          eval {...} called at /home/----/eclipse_workspaces/workspace2/.metadata/.plugins/org.epic.debug/perl5db.pl line 0
      BEGIN failed--compilation aborted.
      at /home/dcuestas/eclipse_workspaces/workspace2/prueba/prueba.pl line 0
      Can't use an undefined value as a symbol reference at /home/----/eclipse_workspaces/workspace2/.metadata/.plugins/org.epic.debug/perl5db.pl line 7496.
      at /home/----/eclipse_workspaces/workspace2/.metadata/.plugins/org.epic.debug/perl5db.pl line 7496
          DB::print_help('Debugged program terminated.  Use B<q> to quit or B<R> to res...') called at /home/----/eclipse_workspaces/workspace2/.metadata/.plugins/org.epic.debug/perl5db.pl line 2035
          DB::DB called at /home/----/eclipse_workspaces/workspace2/.metadata/.plugins/org.epic.debug/perl5db.pl line 9422
          DB::fake::at_exit() called at /home/----/eclipse_workspaces/workspace2/.metadata/.plugins/org.epic.debug/perl5db.pl line 8994
          DB::END() called at /home/----/eclipse_workspaces/workspace2/prueba/prueba.pl line 0
          eval {...} called at /home/----/eclipse_workspaces/workspace2/prueba/prueba.pl line 0
      END failed--call queue aborted.
      at /home/----/eclipse_workspaces/workspace2/prueba/prueba.pl line 0

       
    • David Cuestas
      David Cuestas
      2008-06-03

      I found some things I haven't tried, Let's see ...
      And here goes the log from eclipse with the debbuger option activated:

      !MESSAGE Starting Perl debugger:
      Command line:
      perl
      -I/home/dcuestas/eclipse_workspaces/workspace2/.metadata/.plugins/org.epic.debug
      -I/home/dcuestas/eclipse_workspaces/workspace2/prueba
      -d
      -w
      -T
      -Mautoflush_epic
      /home/dcuestas/eclipse_workspaces/workspace2/prueba/prueba.pl
      Working directory: /home/dcuestas/eclipse_workspaces/workspace2/prueba
      Environment:
      SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
      XAUTHORITY=/tmp/.gdmRZXBCU
      CVS_RSH=ssh
      KDE_NO_IPV6=1
      GDM_XSERVER_LOCATION=local
      SPRINT_HOME=/home/----/Programas/upc_software/sprint
      LESSOPEN=|/usr/bin/lesspipe.sh %s
      KDE_IS_PRELINKED=1
      SSH_AUTH_SOCK=/tmp/ssh-bqmGWm3521/agent.3521
      PWD=/home/dcuestas
      LANG=es_ES.UTF-8
      USER=-----
      GNOME_DESKTOP_SESSION_ID=Default
      G_BROKEN_FILENAMES=1
      OGMIOS_HOME=/home/----/Programas/upc_software/svn_veu/ogmios
      LOGNAME=dcuestas
      TPCAT_HOME=/home/----/upc_tpc/tpcat
      SHLVL=1
      INPUTRC=/etc/inputrc
      PATH=/usr/kerberos/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/sbin:/usr/local/bin:/home/----/Programas/apache-uima/bin:$/UIMACPP_HOME/bin:/home/dcuestas/Programas/upc_software/svn_veu/ogmios/../ramses/bin:/home/dcuestas/Programas/srilm/bin/i686:/home/dcuestas/Programas/srilm/bin
      HISTSIZE=1000
      TERM=dumb
      XMODIFIERS=@im=none
      JAVA_HOME=/usr/java/jre1.6.0_02
      HOME=/home/----
      DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-d9tcbwZRWB,guid=4e854cdace22d5b04f5bac004844e31b
      SSH_AGENT_PID=3577
      XFILESEARCHPATH=/usr/dt/app-defaults/%L/Dt
      LD_LIBRARY_PATH=/usr/java/jre1.6.0_02/lib/i386/server:/usr/java/jre1.6.0_02/lib/i386:/usr/java/jre1.6.0_02/../lib/i386:/usr/lib/firefox-1.5.0.12
      DISPLAY=:0.0
      GTK_RC_FILES=/etc/gtk/gtkrc:/home/----/.gtkrc-1.2-gnome2
      UIMACPP_HOME=/home/----/Programas/apache-uima/uimacpp
      TRANSLATION_MODELS_HOME=/home/----/Programas/upc_software/traductor
      GDMSESSION=default
      MAIL=/var/spool/mail/----
      MOZILLA_FIVE_HOME=/usr/lib/firefox-1.5.0.12
      GNOME_KEYRING_SOCKET=/tmp/keyring-VV0QVi/socket
      HOSTNAME=d52re16cue82
      DESKTOP_SESSION=default
      LS_COLORS=
      SHELL=/bin/bash
      S2S_HOME=/home/----/s2s
      KDEDIR=/usr
      UIMA_HOME=/home/----/Programas/apache-uima
      NLSPATH=/usr/dt/lib/nls/msg/%L/%N.cat
      SESSION_MANAGER=local/d52re16cue82:/tmp/.ICE-unix/3521
      PERLDB_OPTS=RemotePort=0:0:0:0:0:0:0:1:5000 DumpReused ReadLine=0

       
    • David Cuestas
      David Cuestas
      2008-06-03

      Ok, I've solved the problem finally

      it was something related with my /etc/host/ file, I don't know why, the adress 127.0.0.1 pointed to nowhere so I fix it, to point to my machine and then the plugin works perfectly.

      Thanks for the help, and congratulations for the job done