Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

un-indenting problem

Help
Manni
2007-07-23
2013-05-20
  • Manni
    Manni
    2007-07-23

    Hi,

    I am working with EPIC 0.6.11 and I sometimes come across the problem that sometimes blocks of source code cannot be unindented. Nothing happens in cases like that when I press shift-TAB. I can indent the text and then unindent back to the original indentation, but I simply cannot unindent.

    It seems that to reproduce the problem, you need at least one empty line in the selected source code. The lines have to be completely empty with no dangling white space. In the case of trailing tabs or spaces (something which I really hate in my sources), the problem will not show up.

    Regards,
    Manni

     
    • Manni
      Manni
      2007-07-27

      Anyone? Am I alone with this or can other folks replicate the problem?

      Manni

       
      • Jan Ploski
        Jan Ploski
        2007-07-27

        I think the problem is caused by using both tabs and spaces for indentation in the same source file. I remember having experienced it, but did not replicate it so far.

         
        • justsomeone
          justsomeone
          2008-05-20

          Create a new file and enter 2 lines:
              use strict;
              use warnings;
          prefixed by 4 spaces. Select both lines and press Shift+Tab: nothing happens. Press Tab: lines become indented +1 level. Press Shift+Tab: lines become indented -1 level. Press Shift+Tab again: nothing happens. Replace leading 4 spaces with tabs, select lines and press Shift+Tab again: everything works as expected.

          Similar procedure for Java (using 'import ...') works as expected, so it seems like an EPIC problem. I have version 0.5.45 installed.

          Just wonder why there is only one thread addressing this probem.

           
          • Jan Ploski
            Jan Ploski
            2008-05-20

            If you have "Use spaces instead of tabs" and "Insert tabs/spaces on indent == 4" in preferences, then the problem is not reproducible (it works as expected). But I agree with you that it probably would make sense for SHIFT-TAB to delete the number of spaces matching the displayed tab width. File a bug report...

             
            • justsomeone
              justsomeone
              2008-05-20

              Thanks, with that settings it works fine. So I filed a feature request #1968271.