Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Problem while installing EPIC on E 3.2.2

Help
2007-06-04
2013-05-20
  • Serg V. Gulko
    Serg V. Gulko
    2007-06-04

    Hello!

    I tried to install EPIC on my Eclipse 3.2.2 and have next error:

    Resulting configuration does not contain the platform

    I tried to run installtion with debug and stable versions and for both have similar error.
    Any idea how to solve it?

    Serg

     
    • Jan Ploski
      Jan Ploski
      2007-06-04

      Maybe you installed the version of Eclipse without JDT? In such case, try installing Eclipse with JDT. Theoretically, EPIC does not require JDT, but there might be some hidden dependency lurking somewhere.

       
    • Serg V. Gulko
      Serg V. Gulko
      2007-06-04

      No, I already have JDT installed(3.2.2) and also JDT SDK... Maybe I need re-compile epic for my platform?

       
      • Jan Ploski
        Jan Ploski
        2007-06-04

        There is no platform-specific code in EPIC, so no need to recompile. How did you install - using the update manager or by downloading and unpacking EPIC? Both ways should work, but maybe try another route to see if it fails. You can also go to Manage Configuration in menu Help and check that all features are enabled (if you can start Eclipse at all, that is).

         
      • Jan Ploski
        Jan Ploski
        2007-06-04

        When experimenting with different installation methods, it may be useful to uninstall EPIC first...
        1. Close Eclipse
        2. Delete plugins/org.epic.* and features/org.epic.*
        3. Restart Eclipse with the command-line parameter "-clean"

         
    • Serg V. Gulko
      Serg V. Gulko
      2007-06-05

      Take a look on this error...Do you have any idea?

      !ENTRY org.eclipse.update.core 4 0 2007-06-06 00:27:45.445
      !MESSAGE Unable to retrieve remote reference "http://e-p-i-c.sf.net/updates/features/org.epic.feature.main_0.3.0.jar". [Server returned HTTP response code: "404 Not Found" for URL: http://e-p-i-c.sf.net/updates/features/org.epic.feature.main_0.3.0.jar.\]
      !STACK 0
      org.eclipse.update.internal.core.FatalIOException: Server returned HTTP response code: "404 Not Found" for URL: http://e-p-i-c.sf.net/updates/features/org.epic.feature.main_0.3.0.jar.
          at org.eclipse.update.internal.core.UpdateManagerUtils.checkConnectionResult(UpdateManagerUtils.java:561)
          at org.eclipse.update.core.ContentReference.getInputStream(ContentReference.java:153)
          at org.eclipse.update.core.FeatureContentProvider.asLocalReference(FeatureContentProvider.java:268)
          at org.eclipse.update.internal.core.FeaturePackagedContentProvider.getFeatureEntryArchiveReferences(FeaturePackagedContentProvider.java:157)
          at org.eclipse.update.internal.core.FeaturePackagedContentProvider.getFeatureManifestReference(FeaturePackagedContentProvider.java:83)
          at org.eclipse.update.internal.core.FeaturePackagedFactory.createFeature(FeaturePackagedFactory.java:39)
          at org.eclipse.update.core.Site.createFeature(Site.java:527)
          at org.eclipse.update.core.FeatureReference.createFeature(FeatureReference.java:122)
          at org.eclipse.update.core.FeatureReference.getFeature(FeatureReference.java:110)
          at org.eclipse.update.core.FeatureReference.getFeature(FeatureReference.java:97)
          at org.eclipse.update.internal.search.SiteSearchCategory$FeatureDownloader.run(SiteSearchCategory.java:234)
          at java.lang.Thread.run(Thread.java:619)

      !ENTRY org.eclipse.core.jobs 4 2 2007-06-06 00:28:45.679
      !MESSAGE An internal error occurred during: "Update Manager".
      !STACK 0
      java.lang.ArithmeticException: / by zero
          at org.eclipse.update.internal.ui.views.FindUpdatesAction$TrackingProgressMonitor.updateStatus(FindUpdatesAction.java:73)
          at org.eclipse.update.internal.ui.views.FindUpdatesAction$TrackingProgressMonitor.beginTask(FindUpdatesAction.java:53)
          at org.eclipse.update.search.UpdateSearchRequest.performSearch(UpdateSearchRequest.java:267)
          at org.eclipse.update.ui.UpdateJob.runUpdates(UpdateJob.java:207)
          at org.eclipse.update.ui.UpdateJob.run(UpdateJob.java:168)
          at org.eclipse.update.internal.ui.views.FindUpdatesAction$TrackedUpdateJob.run(FindUpdatesAction.java:93)
          at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)

       
      • Jan Ploski
        Jan Ploski
        2007-06-06

        The first error can be safely ignored (will be fixed in a future release of stable nonetheless). The second one looks bad. Have you also tried installing the "testing" version of EPIC (via update site http://e-p-i-c.sf.net/updates/testing\)?

         
      • Jan Ploski
        Jan Ploski
        2007-06-06

        There is an open bug report in Eclipse regarding the ArithmeticException, https://bugs.eclipse.org/bugs/show_bug.cgi?id=184022

        However, no explanations or solutions there.

        I hope that you are following the installation instructions from the EPIC User's Guide and/or the README contained in the downloaded update site file, not unpacking this file into $ECLIPSE_HOME directly, or unpacking the contained jars, or doing anything strange like that.

         
    • Serg V. Gulko
      Serg V. Gulko
      2007-06-06

      Finally I have found what was wrong with installation...

      Take a look(i am running 3.2.2)

      EPIC (0.6.6) requires feature "org.eclipse.platform (3.2.0)", or compatible.

      Any ideas?

       
      • Jan Ploski
        Jan Ploski
        2007-06-07

        Well, it's true, the testing version of EPIC requires at least Eclipse 3.2, as stated in documentation. Nothing wrong with that.

        The feature org.eclipse.platform belongs to Eclipse, check out the subdirectories under $ECLIPSE_HOME/features, there should be one called org.eclipse.platform_3.2.0.v20060609m-AgOexn6hlEUsvBO or the like. Are you saying that YOUR version of org.eclipse.platform is not considered "compatible" with "3.2" by Eclipse?

        In any case, you can edit $ECLIPSE_HOME/features/org.epic.feature_XXX/feature.xml to remove the declared dependency on org.eclipse.platform if you think it causes the problem. However, as noone else seems to have that problem, I suspect that it's something specific to your environment rather than to EPIC's feature.xml.

         
    • Ingo Wiarda
      Ingo Wiarda
      2007-06-10

      I am unable to install EPIC too, neither the stable nor the testing version works for me:

        ----- Current configuration problems -----
          Resulting configuration does not contain the platform.
        ----- Configuration problems after the operation -----
          Resulting configuration does not contain the platform.
          EPIC (0.6.7) requires feature "org.eclipse.platform (3.2.0)", or compatible.

      Eclipse reports itself as
      Version: 3.2.2
      Build id: M20070212-1330 (Fedora release 6.93 (Rawhide))
      /usr/share/eclipse/org.eclipse.platform_3.2.2.r322_v20070117b

      I also could not find a dependency on a specific eclipse platform in org.epic.feature_XXX/feature.xml (on stable) - are you sure this is the correct file?

       
      • Jan Ploski
        Jan Ploski
        2007-06-10

        > I also could not find a dependency on a specific eclipse platform
        > in org.epic.feature_XXX/feature.xml (on stable) - are you sure this is the correct file?

        There is no dependency in 'stable'. The dependency is only stated explicitly in feature.xml of 'testing'.

        You may want to experiment by removing this dependency altogether or by changing match="compatible" to match="greaterOrEqual", which is the fuzziest match possible.

         
        • Ingo Wiarda
          Ingo Wiarda
          2007-06-11

          I have been successful installing EPIC on a fresh install of vanilla Eclipse 3.2.2 in ~/eclipse/...
          It seems that the problem lies within the Fedora-7-package of Eclipse.

           
      • Jan Ploski
        Jan Ploski
        2007-06-10

        BTW, your Eclipse build id is exactly the same as mine, so it should work.

        You can also go to Help/Software Updates/Manage Configuration and check if the features listed there do not appear as disabled or strange in some way (remember to click on the "Show Disabled Features" button in that dialog). This is also where you can disable/enable and remove features in an organized way. Restarting Eclipse with the "-clean" switch on the command line is another idea which might help.