Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Failing to create PerlDB-Interface !!!

Help
2005-06-01
2013-05-20
  • That is the exact message I am getting when trying to run my Perl projects in Debug mode. Under details>>> there is a very helpful message: "null".

    Then it's a launching error with this stack trace:
    An internal error occurred during: "Launching".
    java.lang.NullPointerException
    org.epic.debug.DebugTarget.isTerminated(DebugTarget.java:188)
    org.epic.debug.LaunchConfigurationDelegate.launch(LaunchConfigurationDelegate.java:136)
    org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:569)
    org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(DebugUIPlugin.java:788)
    org.eclipse.debug.internal.ui.DebugUIPlugin$6.run(DebugUIPlugin.java:955)
    org.eclipse.core.internal.jobs.Worker.run(Worker.java:66)

    The whole Eclipse 3.0.1 installation is copied from another computer, where it used to work perfectly, with EPIC .10, under Windows 2000 and Perl from Cygwin. Now I have a new machine and replicated the configuration (including installing padwalker) except that the whole Eclipse dir was copied.

    Any ideas? Thanks in advance.

     
    • I just did the counter-intuitive thing and set the interpreter type from Cygwin to Standard in the EPIC configuration - and now it works.

      Rather non-obvious, considering that I do have a true-blue Cygwin and no other Perl on my machine...