Execution and debugging doesn't work in 0.6.6

Help
2007-06-06
2013-05-20
  • Hi,

    I installed EPIC 0.6.6 and when i try to execute or debug a script, i get this error message:

    Fatal: failed to find source perl5db.pl for epic_breakpoints.pm

    This is Windows XP
    Eclipse 3.2.2
    EPIC 0.6.6
    Cygwin Perl 5.8.7
    PadWalker 1.5

     
    • Jan Ploski
      Jan Ploski
      2007-06-06

      This is Cygwin-specific bug, will be fixed in 0.6.7 (I hope - I have no access to WinXP with Cygwin).

       
  • Dmitry Katsubo
    Dmitry Katsubo
    2011-06-24

    I've got the same problem. Any workarounds?

    Test script output:

    === cut ===
    $ perl -e 'foreach $t(@INC) {print "Found perl5db.pl in $t!\n" if (-e "$t/perl5db.pl");}'
    Found perl5db.pl in /usr/lib/perl5/5.10!
    === cut ===

    Environment:
    WinXP
    Eclipse Helios SR2
    Cygwin Perl 5.10.1
    EPIC 0.6.40

     
  • Dmitry Katsubo
    Dmitry Katsubo
    2011-06-24

    Sorry, I've found the answer myself: one need to change the preference option:

    Preferences → Perl EPIC → Interpreter Type → choose "Cygwin"

    See here.

     
  • Jan Ploski
    Jan Ploski
    2011-06-24

    Is your interpreter type set to "Cygwin" in Preferences? What is the output of "mount"? EPIC needs to resolve the Cygwin path "/usr/lib/perl5/5.10/perl5db.pl" into the corresponding Windows path, which might be failing.

     
  • Dmitry Katsubo
    Dmitry Katsubo
    2011-06-24

    jploski, thank you for comment!

    I have solved the issue by setting that preference. I suppose EPIC makes the autodetection only at installation time, and I have installed Cygwin after I've installed EPIC.

     
  • ccxavier
    ccxavier
    2012-07-25

    I have recently installed EPIC perl on Eclipse and I have installed cygwin. Here's my versions and configurations:

    - using Windows XP
    - cygwin perl version is v5.10.1
    - perl5db.pl is in C:\cygwin\lib\perl5\5.10
    - in my windows environment, I set path to C:\cygwin\lib\perl5\5.10 and C:\cygwin\bin
    - I set the Interpreter Type to Cygwin in Eclipse

    When I click Run from Eclipse to run the Perl program, I kept on getting this error:

    Fatal: failed to find source perl5db.pl for epic_breakpoints.pm (searched in C:\cygwin\lib\perl5\5.8.8\msys;C:\cygwin\lib\perl5\5.8.8;C:\cygwin\lib\perl5\site_perl\5.8.8\msys;C:\cygwin\lib\perl5\site_perl\5.8.8;C:\cygwin\lib\perl5\site_perl;C:\cygwin)

    It seems like it's looking for Cygwin Perl version 5.8.8 but I have Cygwin Perl version 5.10.1 installed. I also specified it in the windows environment path to look for perl5db.pl in C:\cygwin\lib\perl5\5.10.

    I have restarted Eclipse many times but it is still looking for perl version 5.8.8.
    How do I fix this problem so Eclipse knows where and what version of Perl to use?

    Thanks.

     
  • Jan Ploski
    Jan Ploski
    2012-07-25

    Did you enter the correct path to Perl inteprerter in EPIC Preferences?

     
  • ccxavier
    ccxavier
    2012-07-25

    Yes, I did.

    From Eclipse, I select Windows -> Preferences -> Perl EPIC
    On the right window, here's my settings:
    Perl executable: perl
    Interpreter type: Cygwin
    (checked) Enable warnings
    (not checked) Enable taint mode
    (not checked) Enable debugger console(experimental)
    (checked) suspend debugger at first statement
    Default Web-Start page: http://
    (checked) Validate source when idel for 0.4 seconds

    if there's another place to set the Perl Interpreter in EPIC Preferences, please advice.

    thanks.

     
  • Jan Ploski
    Jan Ploski
    2012-07-25

    If you enter "Perl executable: perl", then you are relying on your PATH environment variable. Maybe it is wrong and therefore picking up the wrong version of the interpreter. You can also try printig $ENV{PATH} from a script to check it.

     
  • ccxavier
    ccxavier
    2012-07-25

    Thanks for your help.

    I have Java installed to Eclipse earlier. And now, I install EPIC Perl.
    I checked "Perl executable: perl" from Perl EPIC and it's pointing to the perl.exe from c:\program files\java\jdk1.6.0\bin directory, which is not correct.

    I now change Perl executable to point to c:\cygwin\bin\perl.exe and it works fine.

    thanks