Debugging Local varibles in Module

Help
Mat_J
2007-07-04
2013-05-20
  • Mat_J
    Mat_J
    2007-07-04

    Version info:

    Eclipse:

     
    • Mat_J
      Mat_J
      2007-07-04

      Sorry this time:

      Versions:

      Eclipse: Ver 3.3.0
      EPIC: Ver 0.5.37
      ActiveState Perl: Ver 5.8.8 Build 820
      PadWalker Module: Ver 0.10

      Platform Windows XP SP2

      I am new to using Eclipse and EPIC for debugging perl but I am having problems trying to view variables when the debugger steps into Perl Module I have created.

      When debugging the main perl script I can see the local and global variables in the Variable view fine. But as I step through the code and step into a function that is located in the perl module the perl.exe encounters a problem an brings up the error window with the following details:

      Error signature:

      AppName: perl.exe
      AppVer: 5.8.8.820
      ModName: perl58.dll
      ModVer: 5.8.8.820
      Offset: 0000ce81

      However if I have the Variable View in the background, or if I turn off "Show local variables"  there is no error generated.It seems that the error only occurs if the variable view is active, and you are trying to view local variables and step out of the main perl code.

      Any ideas what could be causing this, any help would be gratefully appreciated.

       
      • Jan Ploski
        Jan Ploski
        2007-07-04

        Try upgrading to 0.6.11 (its debugger code is quite different from 0.5.x). Another idea is to try upgrading PadWalker using the PPM package manager included in the ActiveState Perl distribution. Based on your description, the problem is likely a bug in ActiveState Perl or perhaps some native code in some Perl module, not EPIC.

         
    • Mat_J
      Mat_J
      2007-07-05

      Thanks Jan.

      I installed EPIC test version 0.6.11, and re-tested displaying the local variables when stepping into the perl module. It seems to be working fine now.

      Thanks again.