Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

$^RE_TRIE_MAXBUF 65536 in debuger

Help
harvy76
2008-05-16
2013-05-20
  • harvy76
    harvy76
    2008-05-16

    Hello, I am begginer in Perl, and I would like to use Eclipse with EPIC for programing the scripts. But, I had Eclipse SDK 3.1.2, EPIC 0.5.45. When i try to debug with key F11 the variables window show me this variable /$^RE_TRIE_MAXBUF 65536/
    and in debug window show me
    /Perl Debugger
        <suspended>Main Thread
            preklad.pl[line: 7]

    /
    Please can you help me, where i make a mistake?
    Thank you
    Jan

     
    • Jan Ploski
      Jan Ploski
      2008-05-16

      I can't really see which part of the output you don't like, but it may be sensible to upgrade to the current version of Eclipse (3.3.x) and EPIC 'testing' (0.6.23).

       
    • harvy76
      harvy76
      2008-05-19

      Hi,
      great, thank you for your help. I Installed the last version of Eclipse, and last version of EPIC, and now it is work.
      Thank you.
      Jan

       
    • Mark Rich
      Mark Rich
      2008-05-23

      Hi,

      I have a current Eclipse build (3.3.2) and EPIC version 0.5.45 and I am having the same trouble.
      My question is what the difference is between my version of EPIC and the 'testing' version.
      I'm new to Perl, but this is my dev machine and I don't want to put anything on it that will compromise its stability.

      Is there a way that I can get the debugger to work without using a 'testing' version of the package?

      Thanks,
      -Mark

       
      • Jan Ploski
        Jan Ploski
        2008-05-25

        The 'testing' version has a lot of changes in the debugger code. For this reason debugger fixes generally only go into 'testing', while other fixes also go into 'stable'. Additionally, testing gets new features while stable doesn't (see "Feature Request" entries in the ChangeLog).

        You don't have to uninstall stable and you can always easily switch back to it using Help/Manage Configuration) if you discover some problem in 'testing', but I predict it won't be necessary.