Cannot see array variables in debugger.

Help
Murugesan
2007-08-23
2013-05-20
  • Murugesan
    Murugesan
    2007-08-23

    Hi..
         I am using latest testing version of EPIC, PADWalker 1.5 and Perl 1.5.8. When i was trying to debug, i am getting error message in side Variable viewer. Error Msg "An error occurred while dumping array content; contents of the Variables view may become invalid". but normal variables(non array) are displaying properly. Can anybody can help me.

    My script:

    use strict;
    my @old=('10','20','30','40','50','60','70','80','90','100');
    my @new;
    print "Old = @old\nNew = @new\n";
    foreach(@old)
    {
        push @new,$_;
    }
    print "\nOld = @old\nNew = @new\n";

     
    • Jan Ploski
      Jan Ploski
      2007-08-23

      Your example works ok for me. For further assistance, post the content of the debugger console (see previous messages about troubleshooting debugger) and of the error log ($WORKSPACE/.metadata/.log).

       
    • websdaleandrew
      websdaleandrew
      2008-04-12

      I'm having exactly the same problem.When I switch tabs to breakpoints & back again, all the $ variables are now displayed but the ARGV array seems to defeat it (also I've just seen the same error except referring to Local variables)

       
    • websdaleandrew
      websdaleandrew
      2008-04-13

      I had the same problem - I had installed the Debian gcj version - I removed it & installed the one from Eclipses site & pointed it at sun java 6 - no problem!