Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

New to Perl, new to EPIC - Installation help!

DemiSheep
2012-02-17
2013-05-20
  • DemiSheep
    DemiSheep
    2012-02-17

    I am new to perl and I am trying to install the EPIC plugin for Eclipse but I am not being very successful.

    I am trying to install EPIC using the instructions here: http://www.epic-ide.org/download.php

    I get an error that says: "Communication with repository http://www.epic-ide.org/download.php failed, connection timeout"

    I had this same exact problem a few weeks ago. I thought the server might just be down but it still is having the same issue.

    When I try to install EPIC manually by downloading the zip file and pointing the software installer in Eclipse to the directory where the files are the thing sits there forever thinking about what to do, then it starts doing something and then thinks again forever and I just cancel it as it seems it's going to sit there forever.

    Eclipse Version:

    Version: 3.7.0.v20110530-9gF7UHNFFt4cwE-pkZDJ7oz-mj4OSEIlu9SEv0f
    Build id: I20110613-1736

    I think I might have a clue to my problem. I think I may have the wrong version of Eclipse. This is the Java/Javascript version. What version of Eclipse should I use to install EPIC?

    Please give me any advice you have, as well as advice for using EPIC and debugging etc with Perl.

    DemiSheep

     
  • Jan Ploski
    Jan Ploski
    2012-02-17

    You're probably using a wrong address for the update site. The correct address is: http://www.epic-ide.org/updates/testing

    I just tried with the same build of Eclipse as you reported - worked fine. It should not matter which distribution of Eclipse you use. I prefer "Eclipse Classic".

     
  • DemiSheep
    DemiSheep
    2012-02-17

    Hm, well I installed Eclipse classic and then tried again, it took a while but the update address I was using finally worked. It did take a while though.

    Thanks.