#598 Variable viewing

v0.5.x
open-works-for-me
Stephan Ruehl
Debugger (177)
9
2010-11-05
2010-08-31
Anh Nguyen
No

Hallo everybody,
I'm a new one in perl with EPIC. This problem is now confusing me,
When i run a debug session, step into, step over, etc works well, but there is nothing in Variable View.
Anybody know Why ?
Thanks in advanced. Very Appreciate!

Discussion

  • Anh Nguyen
    Anh Nguyen
    2010-08-31

    • priority: 5 --> 7
     
  • Michael Wilson
    Michael Wilson
    2010-11-04

    I have the same problem on both OS X and Win XP. Could this be a path or ENV variable problem?

     
  • Anh Nguyen
    Anh Nguyen
    2010-11-05

    Hi boskyo, i think that it is not problem you have mentioned. That is problem of compatibility between Epic and Eclipse.

    I have reinstalled Eclipse 3.1.0 for WinXP and the last version of Epic 0.5.46. Or Eclipse 3.1.2 for Ubuntu Hardy Heron 8.04.4, not the last version of Ubuntu, because there is a problem with window system on this OS. And it run well without the problem of variable viewing more.

    You can try it, i hope this help you.

     
  • Anh Nguyen
    Anh Nguyen
    2010-11-05

    • summary: Variabes view --> Variable viewing
     
  • Anh Nguyen
    Anh Nguyen
    2010-11-05

    • priority: 7 --> 9
     
  • Anh Nguyen
    Anh Nguyen
    2010-11-05

    • milestone: 706046 --> v0.5.x
    • status: open --> open-works-for-me
     
  • Michael S
    Michael S
    2011-02-28

    I second the problem: variables view is empty; "expressions" view reports something like:
    "$a" <error(s)_during_the_evaluation>
    "$_" <error(s)_during_the_evaluation>

    My system: Windows XP Pro and Windows 7 (I use EPIC on several machines), Eclipse 3.6.1, Active PERL 5.12, EPIC 0.6.1

    Would appreciate some advice.
    Thanks,
    Michael