#58 POD: Missing =cut kills performance

closed-fixed
nobody
None
5
2005-01-25
2004-05-18
mbildner
No

First, Many Thanks for EPIC!

I noticed that the perl editor became extremely slow
when I was editing a package (SPAMPD). I believe that
I traced it to a lack of a final POD documentation =cut
at the end. The POD documentation is pretty lengthy in
the code.

I believe that the =cut at the end is optional, yes, or
that it is common to leave it off if at the end of a
module? (see
http://search.cpan.org/~nwclark/perl/pod/perlpod.pod\)

Before I found this I ended up replicating the problem on
Fedora Core 1 (w/ dual 2.4ghz processors), WinXP Pro,
and WinXP Home, with various versions of java and a
few versions of perl on the WinXP machines. Boy do I
wish I had worked over the code first, but I assumed it
was OK because I run it already.

source can be found at
http://www.worlddesign.com/Content/rd/mta/spampd/sp
ampd

Sorry for wasting time if this is Not a Bug. I am not a
perl pro, which is why EPIC will be so useful to me.

Discussion

  • Logged In: YES
    user_id=1100436

    Hi,

    I'm having this problem (editor gets slow, saving of a file
    lasts > 5s with 100% Java CPU usage all the time) with a
    self written module.

    I do have this =cut add the end of my POD.

    When I save my module file with my POD, it lasts >5s with
    full CPU usage. When I save it WITHOUT the POD, saving lasts
    ~1s.

    The module can be found at
    http://www.schnuecker.de/perl/Weather/Com.pm

     
  • LeO
    LeO
    2004-10-12

    Logged In: YES
    user_id=703323

    Frankly said, didn't check your input, but is this still a problem
    in 0.3.8???

     
  • LeO
    LeO
    2005-01-25

    • status: open --> closed
     
  • LeO
    LeO
    2005-01-25

    Logged In: YES
    user_id=703323

    I found situation where it might be a problem. Fixed in 0.3.9.

    If problem still exists => new Bug-Entry.

     
  • LeO
    LeO
    2005-01-25

    • status: closed --> closed-fixed