Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#53 Error Logged from Debug UI

v0.1.0
closed-fixed
Stephan Ruehl
Debugger (177)
5
2004-05-30
2004-04-22
danton_78
No

I cannot neither debuug nor run Perl scripts. When I
try it I get the next error pop-up:

Exception occurred during launch
Reason: Error within Debug UI:

In the Eclipse Error Logs I can read:

java.version=1.4.2_03
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=es_ES
Command-line arguments: -os linux -ws gtk -arch x86
-install file:/usr/local/eclipse/

java.lang.reflect.InvocationTargetException
at
org.eclipse.jface.operation.ModalContext.run(ModalContext.java:283)
at
org.eclipse.jface.dialogs.ProgressMonitorDialog.run(ProgressMonitorDialog.java:357)
at
org.eclipse.debug.ui.DebugUITools.launch(DebugUITools.java:494)
at
org.eclipse.debug.ui.actions.LaunchAction.run(LaunchAction.java:66)
at
org.eclipse.debug.ui.actions.LaunchAction.runWithEvent(LaunchAction.java:81)
at
org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:456)
at
org.eclipse.jface.action.ActionContributionItem.handleWidgetEvent(ActionContributionItem.java:403)
at
org.eclipse.jface.action.ActionContributionItem.access$0(ActionContributionItem.java:397)
at
org.eclipse.jface.action.ActionContributionItem$ActionListener.handleEvent(ActionContributionItem.java:72)
at
org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:81)
at
org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:923)
at
org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:1847)
at
org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:1639)
at
org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:1402)
at
org.eclipse.ui.internal.Workbench.run(Workbench.java:1385)
at
org.eclipse.core.internal.boot.InternalBootLoader.run(InternalBootLoader.java:858)
at
org.eclipse.core.boot.BootLoader.run(BootLoader.java:461)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native
Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at org.eclipse.core.launcher.Main.basicRun(Main.java:291)
at org.eclipse.core.launcher.Main.run(Main.java:747)
at org.eclipse.core.launcher.Main.main(Main.java:583)
Caused by: java.lang.NullPointerException
at org.epic.debug.DebugTarget.<init>(DebugTarget.java:45)
at
org.epic.debug.LaunchConfigurationDelegate.launch(LaunchConfigurationDelegate.java:58)
at
org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:156)
at
org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(DebugUIPlugin.java:676)
at
org.eclipse.debug.ui.DebugUITools.buildAndLaunch(DebugUITools.java:538)
at
org.eclipse.debug.ui.DebugUITools$2.run(DebugUITools.java:487)
at
org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:101)

I am getting crazy and I don't know how to fix it. Any
suggestions please!!!

Discussion

  • Jochen Ruehl
    Jochen Ruehl
    2004-05-30

    Logged In: YES
    user_id=274815

    Should be fixed in EPIC 0.2.0.
    If not, please reopen.

     
  • Jochen Ruehl
    Jochen Ruehl
    2004-05-30

    • milestone: --> v0.1.0
    • status: open --> closed-fixed