Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#46 Can't load debug UI

v0.1.0
closed-fixed
Stephan Ruehl
Debugger (177)
5
2004-05-30
2004-03-29
Mads Andreasen
No

Setup: Eclipse 2.1.3, Windows 2000, Activestate Perl
5.6.0, SUN Java. 1.4.2_03

I have created a launch configuration for a perl script.
When I try to run it a message box appears: Error
within debug UI.

eclipse log:
!ENTRY org.eclipse.debug.ui 4 120 mar 29, 2004 11:35:08.424
!MESSAGE Error logged from Debug UI:
!STACK 0
java.lang.reflect.InvocationTargetException
at
org.eclipse.jface.operation.ModalContext.run(ModalContext.java:283)
at
org.eclipse.jface.dialogs.ProgressMonitorDialog.run(ProgressMonitorDialog.java:357)
at
org.eclipse.debug.ui.DebugUITools.launch(DebugUITools.java:494)
at
org.eclipse.debug.ui.actions.LaunchAction.run(LaunchAction.java:66)
at
org.eclipse.debug.ui.actions.LaunchAction.runWithEvent(LaunchAction.java:81)
at
org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:456)
at
org.eclipse.jface.action.ActionContributionItem.handleWidgetEvent(ActionContributionItem.java:403)
at
org.eclipse.jface.action.ActionContributionItem.access$0(ActionContributionItem.java:397)
at
org.eclipse.jface.action.ActionContributionItem$ActionListener.handleEvent(ActionContributionItem.java:72)
at
org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:81)
at
org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:840)
at
org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:2022)
at
org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:1729)
at
org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:1402)
at
org.eclipse.ui.internal.Workbench.run(Workbench.java:1385)
at
org.eclipse.core.internal.boot.InternalBootLoader.run(InternalBootLoader.java:858)
at
org.eclipse.core.boot.BootLoader.run(BootLoader.java:461)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native
Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown
Source)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown
Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.core.launcher.Main.basicRun(Main.java:291)
at org.eclipse.core.launcher.Main.run(Main.java:747)
at org.eclipse.core.launcher.Main.main(Main.java:583)
Caused by: java.lang.NullPointerException
at org.epic.debug.DebugTarget.<init>(DebugTarget.java:45)
at
org.epic.debug.LaunchConfigurationDelegate.launch(LaunchConfigurationDelegate.java:58)
at
org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:156)
at
org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(DebugUIPlugin.java:676)
at
org.eclipse.debug.ui.DebugUITools.buildAndLaunch(DebugUITools.java:538)
at
org.eclipse.debug.ui.DebugUITools$2.run(DebugUITools.java:487)
at
org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:101)

Discussion

  • Logged In: NO

    I have the same problem.

     
  • Jochen Ruehl
    Jochen Ruehl
    2004-05-30

    Logged In: YES
    user_id=274815

    Should be fixed in EPIC 0.2.0.
    If not, please reopen.

     
  • Jochen Ruehl
    Jochen Ruehl
    2004-05-30

    • status: open --> closed-fixed