Problem with lighting in the game Call of Cthulhu: Dark Corners of the Earth

Andrew
2014-07-11
2014-07-13
  • Andrew
    Andrew
    2014-07-11

    The lighting seems to have all kinds of issues when trying to run this game through DXWND. I'm by no means an expert on these matters but I've tried to use the manual and alter all kinds of settings with no luck, no matter what I do it comes out looking the same.

    What the game ought to look like: http://i.imgur.com/gzowi2P.jpg
    What it looks like running through DXWND: http://i.imgur.com/6KaRySA.jpg

    No alterations to the in-game settings have been made between the above images.

    Thank you for any help you can provide.

     
    Last edit: Andrew 2014-07-11
  • gho
    gho
    2014-07-11

    Interesting. It looks as if you set the "Disable setting gamma ramp" flag, but I doubt you did.
    I'm going to grab the game and see by myself.

    update

    Yes, I replicated the problem, that is pretty evident.
    Now I got to find a reason and a cure ....

    update 2

    I tried the video brightness option. That works both in the normal game (no DxWnd!) and with DxWnd in non windowized mode, and is not working in Windowed mode. But the type of effect you get adjusting the brightness DOES NOT look like the original game colors. The problem must lay somewhere else ....

     
    Last edit: gho 2014-07-13
  • gho
    gho
    2014-07-13

    Uh, it seems that I fixed it.
    There's some test to be made, but the fix seems to work perfectly for Call of Cthulhu, both in windowed and fullscreen mode.
    Grab the dll in attach and enjoy ....
    Oh, I almost forgot: and thank you very much for helping to find another nasty and sneaky small DxWnd bug!

     
    Last edit: gho 2014-07-13
    Attachments
  • Andrew
    Andrew
    2014-07-13

    Hey, just gave this a shot and it seems to work perfectly for me as well. Glad I could help you find the bug and thank you for continuing to work on and support this great program.