Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#9 requires libreadline.so.4

closed-fixed
Stelian Pop
None
5
2002-04-29
2002-03-18
Anonymous
No

I tried to upgrade a redhat 7.1 system to the latest
version..4b27-1 but it said I need libreadline.so.4.
I have this file is /usr/lib

Discussion

  • Stelian Pop
    Stelian Pop
    2002-03-19

    • assigned_to: nobody --> stelian
     
  • Stelian Pop
    Stelian Pop
    2002-03-19

    Logged In: YES
    user_id=5513

    Who is complaining, rpm -U dump ?

    Is your installed libreadline.so.4 part of a rpm ? (rpm -qf
    /usr/lib/libreadline*)

    Stelian.

     
  • Logged In: NO

    yes part of this rpm readline-4.1-9

     
  • Stelian Pop
    Stelian Pop
    2002-03-20

    Logged In: YES
    user_id=5513

    Who is complaining ?

    Stelian.

     
  • Logged In: NO

    If I did not give a complete answer. rpm -U is complaining
    and my readline is an rpm installed component.

    Thanks

     
  • Stelian Pop
    Stelian Pop
    2002-03-20

    Logged In: YES
    user_id=5513

    What does "rpm -q --provides readline" say ?

    Stelian.

     
  • Logged In: NO

    I have the same problem.

    Command:
    rpm -q --provides readline
    doesn't show libreadline.so.4 (but it shows
    libreadline.so.4.2)

    what wrong? thanks,

    -marke

     
  • Stelian Pop
    Stelian Pop
    2002-04-17

    Logged In: YES
    user_id=5513

    What is wrong is that the binary RPM I provide is build on a
    RedHat 7.2.

    The RH7.2 readline package has the correct dependency
    information (providing libreadline.so.4).

    The RH7.1 readline package is broken, and provides
    libreadline.so.4.2.

    The solution: get the dump.src.rpm and rebuild it, it should
    be very simple: just issue 'rpm --rebuild
    dump-0.4b28.src.rpm' and you're done.

    Stelian.

     
  • Logged In: NO

    New problems:
    bash-2.05# rpm --rebuild dump-0.4b28-1.src.rpm
    Installing dump-0.4b28-1.src.rpm
    error: failed build dependencies:
    e2fsprogs-devel >= 1.18 is needed by dump-0.4b28-1
    libtermcap-devel is needed by dump-0.4b28-1
    readline-devel is needed by dump-0.4b28-1
    bash-2.05#

    -marke

     
  • Stelian Pop
    Stelian Pop
    2002-04-17

    Logged In: YES
    user_id=5513

    These are not problems: in order to rebuild dump, you need
    some -devel packages you can find on your distribution CDs.
    Just install e2fsprogs-devel, libtermcap-devel and
    readline-devel and retry.

    Stelian.

     
  • Logged In: NO

    RedHat 7.1 Dump .4b28

    with this new version I was able to rebuild the src and then build
    and install the rpm correctly. The changes since .4b27 fixed my
    install issues.

     
  • Stelian Pop
    Stelian Pop
    2002-04-29

    Logged In: YES
    user_id=5513

    As per last comment, fixed in 0.4b28

     
  • Stelian Pop
    Stelian Pop
    2002-04-29

    • status: open --> closed-fixed