Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#1 issues with symbolic links

closed
Stelian Pop
None
5
2000-03-10
2000-03-09
TJ McNeely
No

Discussion

  • Subject: KNOP
    To: tj.mcneely@central.sun.com
    MIME-Version: 1.0

    Here is what I did:
    dump -0au /export/backups/sda1.dump /dev/sda1
    restore r -f sda1.dump

    These are the errors (or example of errors) on the
    restore:
    SEE ATTACHED SOFFICE DOC.
    ---
    (pasted)

    ./etc/rc.d/rc0.d/K90network: not found on tape
    restore: ./etc/rc.d/rc0.d/S00killall: cannot create
    special file: Invalid argument
    ./etc/rc.d/rc0.d/S01halt: not found on tape
    restore: ./etc/rc.d/rc0.d/K10xfs: cannot create special
    file: Invalid argument
    ./etc/httpd/conf/access.conf: not found on tape
    restore: ./etc/rc.d/rc0.d/K15httpd: cannot create
    special file: Invalid argument
    ./etc/rc.d/rc0.d/K84apmd: not found on tape
    restore: ./etc/rc.d/rc0.d/K60atd: cannot create special
    file: Invalid argument
    ./etc/rc.d/rc0.d/K45named: not found on tape
    restore: ./etc/rc.d/rc0.d/K15gpm: cannot create special
    file: Invalid argument
    ./etc/rc.d/rc0.d/K05innd: not found on tape
    restore: ./etc/rc.d/rc0.d/K96pcmcia: cannot create
    special file: Invalid argument
    ./etc/rc.d/rc0.d/K20nfs: not found on tape
    restore: ./etc/rc.d/rc0.d/K95kudzu: cannot create
    special file: Invalid argument
    ./etc/rc.d/rc0.d/K00linuxconf: not found on tape
    restore: ./etc/rc.d/rc0.d/K60lpd: cannot create special
    file: Invalid argument
    ./etc/rc.d/rc0.d/K60mars-nwe: not found on tape
    restore: ./etc/rc.d/rc0.d/K50inet: cannot create
    special file: Invalid argument
    ./etc/rc.d/rc0.d/K10pulse: not found on tape
    restore: ./etc/rc.d/rc0.d/K89portmap: cannot create
    special file: Invalid argument
    ./etc/rc.d/rc0.d/K55routed: not found on tape
    restore: ./etc/rc.d/rc0.d/K20rusersd: cannot create
    special file: Invalid argument
    ./etc/rc.d/rc0.d/K20rstatd: not found on tape
    restore: ./etc/rc.d/rc0.d/K20rwhod: cannot create
    special file: Invalid argument
    ./etc/rc.d/rc0.d/K35smb: not found on tape
    restore: ./etc/rc.d/rc0.d/K30sendmail: cannot create
    special file: Invalid argument
    ./etc/rc.d/rc0.d/K50snmpd: not found on tape
    restore: ./etc/rc.d/rc0.d/K87sshd: cannot create
    special file: Invalid argument
    ./etc/httpd/conf/php.ini: not found on tape
    restore: ./etc/rc.d/rc0.d/K16phphttpd: cannot create
    special file: Invalid argument
    ./root/.sagi/ssh-1.2.27/gmp-2.0.2-ssh-2/README: not
    found on tape
    restore: ./etc/rc.d/rc1.d/K05keytable: cannot create
    special file: Invalid argument
    ./etc/rc.d/rc1.d/K60crond: not found on tape
    restore: ./etc/rc.d/rc1.d/K99syslog: cannot create
    special file: Invalid argument
    ./etc/rc.d/rc1.d/K75netfs: not found on tape
    restore: ./etc/rc.d/rc1.d/K90network: cannot create
    special file: Invalid argument
    ./etc/rc.d/rc1.d/S00single: not found on tape
    restore: ./etc/rc.d/rc1.d/S20random: cannot create
    special file: Invalid argument
    ./etc/rc.d/rc1.d/K10xfs: not found on tape
    restore: ./etc/rc.d/rc1.d/K15httpd: cannot create
    special file: Invalid argument
    ./etc/rc.d/rc1.d/K84apmd: not found on tape
    restore: ./etc/rc.d/rc1.d/K60atd: cannot create special
    file: Invalid argument
    ./etc/rc.d/rc1.d/K45named: not found on tape

    ---

    These are symbolic links... is there an option to make
    them dump or restore better??

    Thanks

     
  • Stelian Pop
    Stelian Pop
    2000-03-10

    • assigned_to: nobody --> stelian
     
  • What version of dump/restore are you using?

    On what kind of filesystem are you performing the restore
    (ext2 or
    something else?).

    Stelian.

     
  • is there no -v :)

    We are using the one that came with RedHat Linux 6.1

    I think this is it --> dump-0.4b4-11.i386.rpm

    and of course e2 filesystem...

    The most trouble seems to be the ETC folder...

    I can be more verbose if you want. (--verbose ??)

     
  • Ok, then it's perfectly normal, since this was a bug fixed
    in 0.4b5 (or b6? don't remember). The latest version is
    0.4b15, and I strongly suggest you to upgrade, since many
    bugs, including security ones were fixed...

    As for the version question, since 0.4b7 (approximatelly),
    you can get
    the version of dump/restore by running them without any
    argument.

    Stelian.

     
  • Stelian Pop
    Stelian Pop
    2000-03-10

    • status: open --> closed