#50 EXT2 directory corrupted problem

open-out-of-date
Stelian Pop
dump (75)
5
2002-02-21
2002-01-10
Anonymous
No

SuSE 7.3
dump 0.4b23 (using libext2fs 1.24a of 02-Sep-2001)
or dump 0.4b26 (using libext2fs 1.24a of 02-Sep-2001)
Kernel 2.4.10
Running Amanda-2.4.2p2 or by hand.

When dumping a large root filesystem at night (36GB
Raid0 ICP Vortex Array) I mostly get an error. I can
easily reproduce the error when doing the following:

# dump -0 -f /dev/null /dev/sda3
DUMP: Date of this level 0 dump: Thu Jan 10 08:40:27
2002
DUMP: Dumping /dev/sda3 (/) to /dev/null
DUMP: Added inode 7 to exclude list (resize inode)
DUMP: Label: none
DUMP: mapping (Pass I) [regular files]
DUMP: mapping (Pass II) [directories]
DUMP: estimated 3112024 tape blocks.
DUMP: Volume 1 started with block 1 at: Thu Jan 10
08:40:38 2002
DUMP: dumping (Pass III) [directories]
/dev/sda3: EXT2 directory corrupted while converting
directory #2273386

DUMP: error reading command pipe: Connection reset by
peer
DUMP: error reading command pipe: Connection reset by
peer

I did a fschk on the unmounted /dev/sda3 an everything
was ok. Dumping an even larger filesys (72 GB Raid5 on
the ICP Vortex) causes the same problems.

I also tried e2fsprogs 1.25 with the same (bad)
results.

Discussion

  • Stelian Pop
    Stelian Pop
    2002-01-10

    • assigned_to: nobody --> stelian
     
  • Stelian Pop
    Stelian Pop
    2002-01-10

    Logged In: YES
    user_id=5513

    Did you run the dump on the mounted or on the unmounted
    filesystem ?

    If you did it while it was mounted, could you try again,
    dumping the unmounted filesystem this time ?

    Also, I see you're using a SuSE distribution... Did you
    compile yourself the dump binary, did you get the RPM from
    sourceforge (the static one or the dynamically linked one) ?

    Stelian.

     
  • Stelian Pop
    Stelian Pop
    2002-02-20

    • status: open --> closed
     
  • Stelian Pop
    Stelian Pop
    2002-02-20

    • status: closed --> closed-out-of-date
     
  • Stelian Pop
    Stelian Pop
    2002-02-20

    Logged In: YES
    user_id=5513

    Closed due to lack of feedback.

     
  • Stelian Pop
    Stelian Pop
    2002-02-20

    Logged In: YES
    user_id=5513

    Closed due to lack of feedback.

     
  • Stelian Pop
    Stelian Pop
    2002-02-21

    Logged In: YES
    user_id=5513

    just a test for checking sourceforge slowness...

     
  • Logged In: NO

    Please give me some time, this is a development system for
    moren than 10 SW developers. I'll be able to test this in
    about 2 weeks from now (2002-03-12).

    The SuSE contains 0.4b23-33 and I'm using 0.4b26 (using
    libext2fs 1.24a of 02-Sep-2001) and I'm pretty sure I
    compiled it myself.

     
  • Stelian Pop
    Stelian Pop
    2002-02-21

    • status: closed-out-of-date --> open-out-of-date
     
  • Stelian Pop
    Stelian Pop
    2002-02-21

    Logged In: YES
    user_id=5513

    Ok, I'm reopening the bug then, please post here the results
    once you have the time to do the tests.

    Stelian.

     
  • Terri Eads
    Terri Eads
    2002-04-18

    Logged In: YES
    user_id=519491

    I am having this problem now. Here is my recent email to the
    amanda-users group:

    Hello,

    I've been running Amanda version 2.4.1p1 for quite some time
    now,
    and my Linux boxes have backed up beautifully. Now,
    however, we are
    gradually upgrading to the 2.4.18 kernel under Debian 2.2
    (potato).
    Suddenly, I'm getting these kinds of errors:

    ? /dev/sda6: EXT2 directory corrupted while converting
    directory #391

    from dump (which is version 0.4b25 by default). These are
    inodes
    it's complaining about, and even though I clean them up, it
    happens
    again on another inode in the same filesystem. I'm running
    the latest
    version of e2fsprogs, and tried upgrading dump to the latest
    version
    (0.4b28), but nothing helps. Has anyone by chance seen this
    problem?
    I know it's not related to amanda most likely, but thought
    someone
    might be able to help.

    Thanks,
    --
    Terri Eads Systems Administrator
    eads@ucar.edu Research Applications Program
    (303) 497-8425 National Center for Atmospheric
    Research

     
  • greg wilson
    greg wilson
    2002-05-15

    Logged In: YES
    user_id=545113

    I am also having similar problems dump fails as follows

    DUMP: dumping (Pass III) [directories]
    /dev/sda3: EXT2 directory corrupted while converting
    directory #5150753

    DUMP: Broken pipe

     
  • Stelian Pop
    Stelian Pop
    2002-05-16

    Logged In: YES
    user_id=5513

    A patch for vfs/ext3 was posted today by Stephen Tweedie on
    the ext2/3 and linux kernel mailing lists. This kernel patch
    mentions dump several times, in contexts dealing with
    buffers corruptions etc:

    ftp://ftp.kernel.org/pub/linux/kernel/people/sct/ext3/v2.4/ext3-0.9.18-2.4.19pre8.patch

    Could the people having this problem test this patch and
    report back ?

    Thanks,

    Stelian.

     
  • William Bear
    William Bear
    2003-03-21

    Logged In: YES
    user_id=739230

    ext2 directory corrupted problem

    I've have the same problem dumping live filesystems after
    upgrading to dump .4b33. It dumped fine using .4b11,
    but .4b11 couldn't dump newer filesystems created using
    e2fsprogs 1.32. The problem is occuring on a filesystem that
    was created with an older e2fsprogs 1.25. I'm going to try
    umounting and dumping this weekend, and eliminate that as
    a possiblity. Any more info or suggestions would be great.

    Dump .4b33
    e2fsprog 1.32 nov 2002
    dist loosely based on slack
    kernel 2.4.20
    dump scripts

    Thanks,

    Will

     
  • Stelian Pop
    Stelian Pop
    2003-03-24

    Logged In: YES
    user_id=5513

    > I'm going to try umounting and dumping this weekend

    So, what are the news ?

    Stelian.

     
  • Logged In: NO

    Dump performed fine this weekend. I actually didn't have to
    umount the file system. This system is running samba, and
    the problem seems to occur if a user is logged through
    samba. I also noticed the problem was always occuring in
    the user profile directories. Doesn't seem to be a dump
    problem.

    Sorry,

    Will

     
  • Stelian Pop
    Stelian Pop
    2003-03-24

    Logged In: YES
    user_id=5513

    Ok, thanks Will for testing this up.

    In a way I'm glad it's not a problem with dump but in
    another this still reminds us that dumping an active
    filesystem can really fail provided some conditions are met.

    Stelian.

     
  • Arcady Genkin
    Arcady Genkin
    2003-05-07

    Logged In: YES
    user_id=27110

    FWIW, we are experiencing the exact same problems here, on
    two machines with SCSI disks, always when dumping root file
    systems (mounted). Dumping the same file systems in an
    unmounted state works fine. We are using dump 0.4b34 with
    libext2fs 1.26.

    Although I realize that dumping a live file system is a bad
    thing, sometimes there is no choice but to do it that way.
    It would be very nice if this non-bug could be fixed/worked
    around.

     
  • Stelian Pop
    Stelian Pop
    2003-05-07

    Logged In: YES
    user_id=5513

    antipode, the only possible workaround is to use filesystem
    snapshots.

    You can get those by using LVM or EVMS presenlty.

    In the not so near future the kernel may support snapshots
    even without LVM/EVMS. But it's not for tomorrow.

    Stelian.