Hi ,


Last week I tried to install dsapce 3.0 on windows 7. Installed all the perquisite soft wares (postgresql 8.2,tomcat6,ant 1.8.4,maven 2.2.1,java

I checked all the soft wares to ensure their proper installation. all are working fine. However the following error occurs when I run mvn package.


Can anybody helps on this.


C:\dspace-3.0-src-release\dspace>mvn package

[INFO] Scanning for projects...

[INFO] Reactor build order:

[INFO]   DSpace Addon Modules

[INFO]   DSpace Kernel :: Additions and Local Customizations

[INFO]   DSpace XML-UI (Manakin) :: Local Customizations

[INFO]   DSpace LNI :: Local Customizations

[INFO]   DSpace JSP-UI :: Local Customizations

[INFO]   DSpace SWORD :: Local Customizations

[INFO]   DSpace SWORD v2 :: Local Customizations

[INFO]   DSpace SOLR :: Local Customizations

[INFO]   DSpace OAI 2.0 :: Local Customizations

[INFO]   DSpace Assembly and Configuration

[INFO] ------------------------------------------------------------------------

[INFO] Building DSpace Addon Modules

[INFO]    task-segment: [package]

[INFO] ------------------------------------------------------------------------

[INFO] [enforcer:enforce {execution: enforce-maven}]

[INFO] [site:attach-descriptor {execution: default-attach-descriptor}]

[INFO] ------------------------------------------------------------------------

[INFO] Building DSpace Kernel :: Additions and Local Customizations

[INFO]    task-segment: [package]

[INFO] ------------------------------------------------------------------------

[INFO] [enforcer:enforce {execution: enforce-maven}]

[INFO] [resources:resources {execution: default-resources}]

[INFO] Using 'UTF-8' encoding to copy filtered resources.

[INFO] Copying 1 resource

[INFO] [compiler:compile {execution: default-compile}]

[INFO] Compiling 2 source files to C:\dspace-3.0-src-release\dspace\modules\addi


[INFO] -------------------------------------------------------------


[INFO] -------------------------------------------------------------

[ERROR] Failure executing javac, but could not parse the error:

javac: invalid flag: -s

Usage: javac <options> <source files>

where possible options include:

  -g                         Generate all debugging info

  -g:none                    Generate no debugging info

  -g:{lines,vars,source}     Generate only some debugging info

  -nowarn                    Generate no warnings

  -verbose                   Output messages about what the compiler is doing

  -deprecation               Output source locations where deprecated APIs are u


  -classpath <path>          Specify where to find user class files

  -cp <path>                 Specify where to find user class files

  -sourcepath <path>         Specify where to find input source files

  -bootclasspath <path>      Override location of bootstrap class files

  -extdirs <dirs>            Override location of installed extensions

  -endorseddirs <dirs>       Override location of endorsed standards path

  -d <directory>             Specify where to place generated class files

  -encoding <encoding>       Specify character encoding used by source files

  -source <release>          Provide source compatibility with specified release


  -target <release>          Generate class files for specific VM version

  -version                   Version information

  -help                      Print a synopsis of standard options

  -X                         Print a synopsis of nonstandard options

  -J<flag>                   Pass <flag> directly to the runtime system