Hello,

 

I am trying to get XPDF working however, whenever I run dspace filter-media it “runs” for a couple of seconds and then drops out.  No errors that I can find or anything.

 

Here is my dspace config and other comments below.

 

#Names of the enabled MediaFilter or FormatFilter plugins

filter.plugins = PDF Thumbnail, PDF Text Extractor, HTML Text Extractor, \

                                 PowerPoint Text Extractor, \

                                 Word Text Extractor, JPEG Thumbnail

# [To enable Branded Preview]: remove last line above, and uncomment 2 lines below

#                        Word Text Extractor, JPEG Thumbnail, \

#                        Branded Preview JPEG

 

#Assign 'human-understandable' names to each filter

plugin.named.org.dspace.app.mediafilter.FormatFilter = \

#  org.dspace.app.mediafilter.PDFFilter = PDF Text Extractor, \

  org.dspace.app.mediafilter.XPDF2Text = PDF Text Extractor, \

  org.dspace.app.mediafilter.XPDF2Thumbnail = PDF Thumbnail, \

  org.dspace.app.mediafilter.HTMLFilter = HTML Text Extractor, \

 org.dspace.app.mediafilter.WordFilter = Word Text Extractor, \

  org.dspace.app.mediafilter.PowerPointFilter = PowerPoint Text Extractor, \

  org.dspace.app.mediafilter.JPEGFilter = JPEG Thumbnail, \

  org.dspace.app.mediafilter.BrandedPreviewJPEGFilter = Branded Preview JPEG

 

#Configure each filter's input format(s)

#filter.org.dspace.app.mediafilter.PDFFilter.inputFormats = Adobe PDF

filter.org.dspace.app.mediafilter.XPDF2Thumbnail.inputFormats = Adobe

PDFfilter.org.dspace.app.mediafilter.XPDF2Text.inputFormats = Adobe PDF

filter.org.dspace.app.mediafilter.HTMLFilter.inputFormats = HTML, Text

filter.org.dspace.app.mediafilter.WordFilter.inputFormats = Microsoft Word

filter.org.dspace.app.mediafilter.PowerPointFilter.inputFormats = Microsoft Powerpoint, Microsoft Powerpoint XML

filter.org.dspace.app.mediafilter.JPEGFilter.inputFormats = BMP, GIF, JPEG, image/png

filter.org.dspace.app.mediafilter.BrandedPreviewJPEGFilter.inputFormats = BMP, GIF, JPEG, image/png

 

# XPDF Paths

xpdf.path.pdftotext = /usr/bin/pdftotext

xpdf.path.pdftoppm = /usr/bin/pdftoppm

xpdf.path.pdfinfo = /usr/bin/pdfinfo

 

 

Here is what I get when I run dspace filter-media –v:

The following MediaFilters are enabled:

Full Filter Name: org.dspace.app.mediafilter.HTMLFilter

org.dspace.app.mediafilter.HTMLFilter

Full Filter Name: org.dspace.app.mediafilter.WordFilter

org.dspace.app.mediafilter.WordFilter

Full Filter Name: org.dspace.app.mediafilter.JPEGFilter

org.dspace.app.mediafilter.JPEGFilter

Full Filter Name: org.dspace.app.mediafilter.XPDF2Thumbnail

org.dspace.app.mediafilter.XPDF2Thumbnail

Full Filter Name: org.dspace.app.mediafilter.PowerPointFilter

org.dspace.app.mediafilter.PowerPointFilter

 

 

I am using jai_core-1.1.2_01.jar and jai_imageio-1_1

 

I changed the pom.xml in dspace-src/dspace/pom.xml to point to 1_1 instead of 1.0_01

 

Thank you!

 

Tom