Hello Everyone,

I realised, none of my source files were compiling and rebuilt, as all my class files were 10 days older.

I just used mvn to clean from the root dspace folder instead of the dspace directory.

That cleaned up all the modules, and all the modules were rebuilt. This solved the problem.

All my changes are reflecting and i am able to login using LDAP.

Thanks for the help

On Wed, Aug 29, 2012 at 5:01 PM, Lohit Valleru <lohitv9@gmail.com> wrote:
Hello Helix,

Thank you for the quick reply.

I have tried the below process, to rebuild dspace, but still i do not see any change in the way logs are displayed.

Since everyone follows this similar process. May be there is something else that i am not doing right.

May i please confirm if i am making changes to the right source file : that the changes that we make for the dspace ldap authentication source file - is within this particular directory tree structure : dspace-1.8.2/dspace-api/src/main/java/org/dspace/authenticate/ ?

Thank you

Lohit



On Wed, Aug 29, 2012 at 4:28 PM, helix84 <helix84@centrum.sk> wrote:
Lohit, make sure you're using full build, not quick build:

https://wiki.duraspace.org/display/DSPACE/Rebuild+DSpace

Second thing to try is to run the clean target (mvn clean package).

Regards,
~~helix84